I got Metal Fatigue to work on WINDOWS 7!

#1DylaniusPosted 1/28/2011 10:58:59 PM
Hello Gentlemen!
I see we have all been having issues getting this game to work but I am here to change all of that! HALLELUJAH!

Okay. My computer looks like:
Operating System: Windows 7 Home Premium 32-bit (6.1, Build 7600) (7600.win7_gdr.100618-1621)
System Manufacturer: Gigabyte Technology Co., Ltd.
Processor: Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz (4 CPUs), ~2.4GHz
Memory: 4096MB RAM
Available OS Memory: 2814MB RAM
Page File: 2548MB used, 3078MB available
DirectX Version: DirectX 11
Card name: ATI Radeon HD 4800 Series
Display Memory: 3186 MB
Dedicated Memory: 2035 MB
Shared Memory: 1151 MB
Current Mode: 1600 x 900 (32 bit) (60Hz)
So clearly, I have a modern computer.


FIRST: You MUST MUST MUST MUST download this
http://www.zeckensack.de/glide/archive/GlideWrapper084c.exe

Its a 3dFx glide program that will solve that weird texture problem the game has. I used the latest version of Avast! to scan it for viruses and it came up clean. Ive tried other GLIDE wrapper programs and this is the only one Ive had any luck with.

Download it and install it BEFORE YOU INSTALL METAL FATIGUE.

If Metal Fatigue was installed before, uninstall it and then reinstall. That is absolutely essential.

You must install the game using the CDs or an appropriately ripped image for all you back-up freaks out there.

Then, use Zeck's 3d Glide program (that you just downloaded) and configure it to match the picture exactly.

http://i1203.photobucket.com/albums/bb389/bertbargo/SETTINGS.jpg

My game used to freeze after a few moments but when I used those particular settings, I could play the game no problem.
After configuring, use Metal Fatigue's included Hardware Detect program and use the GLIDE card.

You have to go into your Metal Fatigue desktop shortcut and set:
Compatibility: Win XP SP2
Disable the bottom 3: Visual, Desktop, Scaling
Run program as Admin

Now, for me, it has worked flawlessly! I played the first 2 missions with no issue! I hope it works for all you!
---
Starcraft2
Name: Dielan Character#: 290
#2Dylanius(Topic Creator)Posted 1/29/2011 10:25:39 AM
I also installed the included Directx7 with Metal Fatigue when I installed the game- dont know if that helped with the glide wrapper or not.
---
Starcraft2
Name: Dielan Character#: 290