This is a split board - You can return to the Split List for other boards.

Sorry, there's a problem with the Xbox service. Try again later

#1BladeVaultPosted 9/12/2013 4:32:40 AM
Status code: 800700E8
this is what it said to me when i tried to get the saints row 4 dlc called the dubstep remix pack... Does this mean Volition Banned me from getting it?

Anyway i can download other things perfectly at the xbox game store except for this... And the dubstep remix pack don't even appear at the xbox game store it appears in the main menu of the saints row iv game dlc section....
#2catzrul2002Posted 9/12/2013 8:43:14 AM
Happens with a lot of people with all different items, like I can't download most demos because of this error.

Guess that gold money is really going somewhere, just not the the actual service.
---
Fingers crossed for Sony to enable PSN name change!!
#3Princejake2Posted 9/12/2013 12:49:20 PM
Yeah, I hit the new release demo section and it was showing old demos like FIFA and XCOM as newest, and kept giving me error messages when I tried to get the Diablo 3 demo or the free titles for the month, and I can't get my DLC for my shiny new copy of BF3 Premium I just got home with =/
---
XBL/PSN: Princejake2
DD:DA 360 Pawn: Randgriz Lv 115 Fighter (Tank) Scather/Utilitarian/Pioneer. Veteran Adventurer
#4eggyPosted 9/12/2013 1:18:32 PM
http://support.xbox.com/xbox-live-status
---
http://bdce38.dvdaf.com/owned
http://letterboxd.com/eddielarkin/films/diary/
#5BDJaycePosted 9/12/2013 6:48:22 PM
[This message was deleted at the request of the original poster]
#6rrdm2kPosted 9/13/2013 3:32:44 AM
Microsoft knows about it and are looking into fixing it. I can't see any games through the dashboard or through the website at the moment.

Source: http://www.gamasutra.com/view/news/200164/Microsoft_addressing_technical_glitch_affecting_Xbox_storefront.php
---
"The most merciful thing in the world, I think, is the inability of the human mind to correlate all its contents." - HP Lovecraft
#7MasterPokerPosted 10/3/2013 6:29:40 PM
I just had this happen when trying to purchase Terraria for my son (got billed, but no download offered, wants me to re-purchase), and after 45m of waiting and talking with support, I finally got a workaround:

Go to Settings, Storage, and find the section with Marketplace data, then delete it. Reboot the console. Go to Settings, Account, Download History and find the item you just purchased. You should be able to download it now.
---
http://www.lostlabyrinth.com - Free, addicting rogue-based game
Xuande