The multiplayer won't work, I get a different version error.

#1LiarboyPosted 2/4/2009 6:43:02 PM
even though my friend and I have the same version. Trust me, we've checked. And we've tried the original age of mythology and the titans expansion. We're both updated to the latest version on both.

We're using LAN through Hamachi, but we've also tried direct IP. We still keep getting the incompatable version error. We originally got the "timeout 15 seconds/wait 120 seconds" error, but we finally figured that out, but now the new problem is the incompatable versions. Does anybody have any clue to what might be wrong? I really want to play this game.
#2jure201Posted 3/5/2009 12:48:16 PM

How did u get around the 120 s wait error me and my friends have that error and i can't fix it :roll: