Process changer

#1sabdudePosted 4/12/2012 8:36:29 AM
So I have trouble starting this game, and read on hardcore-gamer5's board that it's a multi core processor problem. I read the fix posted by stratx in the same board. The problem is the link for process changer is dead. So I was wondering if anybody could give me a link to a safe place to download it.
#2TazmanianDPosted 4/16/2012 3:05:31 PM

Are you sure that was a comment on Thief 3 and not Thief 1 and 2. I know the first two had multi-core problems but I didn't think the 3rd one did.

I don't have a link to the tool but there are two other ways you can fix the problem. After starting the game, Alt-Tab out of it (assuming the game doesn't just crash by doing that). Then open the task manager, right click on the thief process and select the "Select Affinity" option and uncheck all but one of the CPUs. Unfortunately you'll have to repeat that every time you start the game.

You should also be able to disable the hyper-threading function of your CPU in your bios although I don't know if you can disable entire cores. But thats a route to try at least to see if it makes the game work.

#3sabdude(Topic Creator)Posted 4/16/2012 9:59:27 PM
Yeah I'm sure it was for this one.
Here's the link:

The problem is it won't even start, nothing happens after I click it. So I don't think that will work.
#4TazmanianDPosted 4/17/2012 2:34:03 PM

You should go check out the forums at That's the best resource for the Thief games.

#5sabdude(Topic Creator)Posted 4/19/2012 9:19:28 AM
Ok thanks I'll try that.
#6sabdude(Topic Creator)Posted 4/22/2012 3:15:36 PM
I checked that site and found something that should have helped. A program called fliptib, and a guide by a moderator there on how to fix it with that program. Except that didn't work, and t3 doesn't even show up in the task manager. So I don't think my problem is with my multi core.
#7sabdude(Topic Creator)Posted 5/9/2012 11:41:30 AM
#8ShadowBanjoPosted 6/7/2012 9:37:10 AM
Thief 3 DOES have a problem with multi-core processors, though. I had to use a program to permanently set affinity to 1 for it to work.