I'm sorry if this is a stupid question, but how can I fix ID conflicts for mods?

#1Marioface5Posted 5/3/2012 2:26:54 AM(edited)
I use Magiclauncher to set up my mods, and I want to use both ThaumCraft 2 and Industrial Craft 2, but I get this problem:


Mods loaded: 21
ModLoader 1.2.5
mod_MinecraftForge 3.1.2.94
mod_PigbearLaser 1.4
mod_Railcraft 5.2.0
mod_stevescarts 1.2.0
mod_CraftGuide 1.4.3 for Minecraft 1.2.3
mod_IC2 v1.95
mod_BuildCraftCore 3.1.5
mod_BuildCraftBuilders 3.1.5
mod_BuildCraftEnergy 3.1.5
mod_BuildCraftFactory 3.1.5
mod_BuildCraftTransport 3.1.5
mod_BuildCraftSilicon 3.1.5
mod_RedPowerCore 2.0pr5b1
mod_RedPowerLogic 2.0pr5b1
mod_RedPowerWiring 2.0pr5b1
mod_RedPowerLighting 2.0pr5b1
mod_RedPowerWorld 2.0pr5b1
mod_RedPowerMachine 2.0pr5b1
mod_RedPowerControl 2.0pr5b1
mod_ThaumCraft 2.1.4

Minecraft has crashed!
----------------------

Minecraft has stopped running because it encountered a problem.




--- BEGIN ERROR REPORT 521b658d --------
Generated 5/3/12 5:23 AM

Minecraft: Minecraft 1.2.5
OS: Windows 7 (amd64) version 6.1
Java: 1.6.0_27, Sun Microsystems Inc.
VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
LWJGL: 2.4.2
OpenGL: GeForce GTX 560 Ti/PCI/SSE2 version 4.2.0, NVIDIA Corporation

java.lang.IllegalArgumentException: Slot 249 is already occupied by thaumcraft.world.BlockCustomPlants@58886ad0 when adding ic2.common.BlockTex@641cab18
at pb.<init>(Block.java:249)
at pb.<init>(Block.java:281)
at ic2.platform.BlockCommon.<init>(BlockCommon.java:12)
at ic2.common.BlockTex.<init>(BlockTex.java:30)
at mod_IC2.load(mod_IC2.java:154)
at ModLoader.init(ModLoader.java:891)
at ModLoader.addAllRenderers(ModLoader.java:189)
at ahu.<init>(ahu.java:77)
at ahu.<clinit>(ahu.java:8)
at net.minecraft.client.Minecraft.a(Minecraft.java:394)
at net.minecraft.client.Minecraft.run(Minecraft.java:732)
at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT a4d9e5be ----------


How can I fix this? Surely there must be a way, especially given that ThaumCraft 2 has something that involves IndustrialCraft 2. I'm sorry if this is a stupid question, but my searching has not helped me out so far.
---
The world gets weirder every day.
PSN: Marioface5
#2Marioface5(Topic Creator)Posted 5/3/2012 2:45:01 AM
I've tried messing around with the config files, but everything I try ends up being something IC2 is already using. Is there anything I can do to:

A. Increase the number of block IDs available

B. Make this thing sort itself out so I don't have to bother with it
---
The world gets weirder every day.
PSN: Marioface5
#3Marioface5(Topic Creator)Posted 5/3/2012 3:03:14 AM
Alrighty! I managed to do this on my own, I feel kind of proud of that. For anyone in the future who needs help and stumbles upon this, here's what I did. All I did was install the InfiCraft 4096 Fix (http://www.minecraftforum.net/topic/521617-125-inficraft/) to increase the number of available block IDs, and then I increased each ID in the ThaumCraft config file by 20. So 249 became 269 and so on.
---
The world gets weirder every day.
PSN: Marioface5
#4Marioface5(Topic Creator)Posted 5/3/2012 3:29:45 AM(edited)
Well this is bad. After all the time I spent on the world I was playing, I may have to start over after all. It seems that ThaumCraft 2 and Red Power 2 decided to change some of my items I had, which really sucks. At least I backed up my saves, I guess.

EDIT: Okay, well starting over won't work because apparently the ID mod I used completely screwed up some IDs, doing things like turning gold ingots into some kind of weird RP2 ore. So I guess I'll just have to remove the ID mod and figure out what to do about the ID problem. So now I'm stuck again.

Help? Please?

EDIT 2: Well it seems that the ID mod by itself doesn't cause problems. If I install Thaumcraft with it active though, everything goes crazy with gold becoming ore and whatnot. I'm so confused.
---
The world gets weirder every day.
PSN: Marioface5
#5galaxiadarknessPosted 5/3/2012 7:06:42 AM
BlogFAQs.
---
A good thing to remember when considering a career in professional gaming:
"Once you go paid, you never get laid."
#6Marioface5(Topic Creator)Posted 5/3/2012 3:38:23 PM
galaxiadarkness posted...
BlogFAQs.

Yeah...In my defense though, it was really late and I had a terrible sinus headache, so common sense (using the edit button every time instead of making new posts) was a bit messed up at the time.

Anyway, does anyone know what I should do here? I never did figure out how to sort this all out, and Thaumcraft 2 looks amazing.
---
The world gets weirder every day.
PSN: Marioface5
#7WorstNightMaresPosted 5/3/2012 8:12:13 PM
Won't work dude. If you have mods that conflict that much, you aren't gonna be able to fix it. I actually tried putting my own custom made pack together, between 45-50 mods, took a little bit to mess with things and switch around the IDs and what not, but the thing is, if you try and mess too much and swap blocks, a looooot of stuff is going to get over written, some blocks are going to replace others, I think at one point I actually got my Rope Arrows to be replaced with my Portal Gun, and in the game when I'd start it up, there would be leaves on trees replaced with some kind of fish block, and when the wind blew, it would blow golden shovels. There's a lot of things I wanted to use, I never really liked mod packs or anything but trust me, doing that kind of thing yourself just isn't gonna work, unless you actually find how to do it like the known modders do.

tl;dr : Don't replace things because you'll only mess it up.
#8What_The_FudgePosted 5/3/2012 8:22:37 PM
The wind was blowing Golden Shovels???

Epic.
---
Been a Brony since 3/15/12
Princess Luna <3 http://30.media.tumblr.com/tumblr_lyovmzwDih1r1y172o1_500.jpg
#9Marioface5(Topic Creator)Posted 5/3/2012 8:39:14 PM
Well obviously there's some way to do it, given that direwolf20 uses all of the conflicting mods I want in his Let's Play series. I'd use ID Resolver, but I can't get that to work because GUI API doesn't seem to work with Magic Launcher for some reason, and no matter how I try to "repackage" mods that don't work with it, nothing seems to help. I wish someone would explain in detail everything I have to do here. How exactly do I repackage things? I've done everything I can think of with the Portal Gun mod sound files and they won't work. It's all extremely frustrating, especially because:

A. I need to use Magic Launcher because I often install and uninstall different mods. If I install them normally, it makes the whole thing a huge mess if I want to uninstall even one mod.

B. The past several days I've been getting these bad (what seem to be) sinus headaches.

Please, if you know how to fix problems with Magic Launcher and "no mods found" errors, or if you know how to get GUI API to work with Magic Launcher, or if you know how to fix ID conflicts or anything at all that can help, please go into as much detail as possible and help me. This is really starting to bother me.
---
The world gets weirder every day.
PSN: Marioface5
#10WorstNightMaresPosted 5/3/2012 10:57:52 PM
Well yeah, obviously it has to work some way, or people wouldn't have done it in the past, but the thing is, until someone either mods in more IDs, or Notch doesn't lie again and actually puts those 4096 block IDs in, it'll be a lot harder is all. Some items don't seem to work no matter what, even if a block ID is available. I'm actually trying to pack more again, and for the moment it's working but I'm trying to install RopesPlus, and I have 2 open IDs, when I actually need exactly 3. I've tried uninstalling other not-so-important mods that I didn't want as much, but even then there still seems to be some kind of conflict.

Granted in all likeliness when I ended up making golden shovels blow in the wind that must show I have no idea in hell what I'm actually doing enough to try and make my own mod pack, but still, unless someone will spoonfeed it to you and give you step by step directions, I don't suggest doing it by yourself.