Trying to set up a Minecraft server for me and some friends.

  • Topic Archived
  1. Boards
  2. Minecraft
  3. Trying to set up a Minecraft server for me and some friends.
5 years ago#1
I keep failing and it says Connection timed out.

Any help? D:
---
hurderp
5 years ago#2
I had trouble with this too.

1. Go to your cmd window, type in ipconfig, and you'll see 3 IP addresses.
2. Type the third IP address into your browser. It will prompt you for a username and password. Chances are they are 'admin' for the user and 'password' for the password. If not you can look up the default ones for your router online.
3. Once logged in, find the 'port forwarding' section, and click add service. Add the port that you want your server to be on to your IP address. Should look like this: http://img441.imageshack.us/i/portforwarding.jpg/
25565 is the default port minecraft uses, so I'd just leave that as it is.
4. Once you've done this, go to your firewall and make this port an exception. You'll have to click add port under the exceptions tab.
5.Start up the Minecraft_server.exe. It should create some files and folders in the same folder that it is in. Once you start it the first time, go to the file server.properties and open it with wordpad. Where it says server-ip, put in your IP address.
6. Give your IP address to your friends so they can connect. You have to have the Minecraft_sever.exe program running in order to connect to the server, so leave it open while you play.

If you have any other questions or need clarification, just ask.
---
" Minecraft has its own genre. Like....HOLY **** SKELETONS OH NO CREEPER sort of genre."
-Black_Fatalis
5 years ago#3
I've been trying to do exactly above but, when I set the IP of the server and try to start it, I get...

**** FAILED TO BIND TO PORT!
[WARNING] The exception was: java.net.BindException: Cannot assign requested address: JVM_Bind
[WARNING] Perhaps a server is already running on that port?

? :(
---
Semper fudge.
5 years ago#4
Looks like you haven't forwarded the port. Did you follow the steps above?
---
" Minecraft has its own genre. Like....HOLY **** SKELETONS OH NO CREEPER sort of genre."
-Black_Fatalis
5 years ago#5

From: IronSasquatch | #004
Looks like you haven't forwarded the port. Did you follow the steps above?


I /think/ I've forwarded the ports.

http://img84.imageshack.us/img84/8846/speedtouchminecraft1286.png
---
hurderp
5 years ago#6
Try changing it to TCP/UDP.
---
" Minecraft has its own genre. Like....HOLY **** SKELETONS OH NO CREEPER sort of genre."
-Black_Fatalis
5 years ago#7

From: IronSasquatch | #006
Try changing it to TCP/UDP.


It's TCP or UDP, not both :l
---
hurderp
5 years ago#8
Hmmm...that's weird. On mine, it has an option for both.

Your server.properties file matches the IP address right? And you allowed that port in your firewall?
---
" Minecraft has its own genre. Like....HOLY **** SKELETONS OH NO CREEPER sort of genre."
-Black_Fatalis
5 years ago#9

From: IronSasquatch | #008
Hmmm...that's weird. On mine, it has an option for both.

Your server.properties file matches the IP address right? And you allowed that port in your firewall?


#Minecraft server properties
#Mon Oct 11 18:59:34 CEST 2010
online-mode=true
monsters=false
server-ip= MY IP from IPConfig3?
server-port=25565
max-players=20
level-name=world


That's correct, right? D:
---
hurderp
5 years ago#10
Looks right to me.
---
" Minecraft has its own genre. Like....HOLY **** SKELETONS OH NO CREEPER sort of genre."
-Black_Fatalis
  1. Boards
  2. Minecraft
  3. Trying to set up a Minecraft server for me and some friends.

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived