Help with Tekkit Sorting Facility

#1WhiteRabbitKiziPosted 6/10/2012 10:11:31 PM
Well I posted this on the Tekkit forums as well but no reply yet, so lets try this site... >_>


I have a sorting facility, and it worked. Not a single issue. Then, it didn't work. Did not change a thing. The facility is based on Redpower 2 and as such uses the machines to sort etc. The layout is as follows: Relay at the input followed by a Sorter. The sorter is connected in line with other sorters. Each sorter adds a color to certain blocks, and if the block is not listed, adds red to pass it on to the next sorter.

Now here is the issue: The first sorter and the Relay are both claiming to be backed up.

Here's what I've done so far:

Replaced the Relay and Sorter: Failed
Tried emptying the Relay and Sorter: Failed
Tried connecting the Sorter to just a chest on the output: Failed
Replaced the entire system with BC sorting pipes using relays to connect to the already existing RP machines: Failed

Basically put, nothing I do will allow for the Relay to output to the Sorting machine or any other machine. Period.

I have connected it directly to a chest and it works, however, connecting it to a pipe leading to a chest fails...

This is really....REALLY... frustrating...

Any ideas would be appreciated >_<
---
GT: WhiteRabbitKizi
#2zeldalordPosted 6/11/2012 12:00:33 AM
Have you tried using a wooden transport pipe? And powering the pipe with a basic redstone engine? The wooden transport pipe when powered "sucks" items out of things.
---
XBL - Gamertag: Zeldalord
"Gravitation is not responsible for people falling in love." - Albert Einstein.
#3natchu96Posted 6/11/2012 12:06:34 AM
zeldalord posted...
Have you tried using a wooden transport pipe? And powering the pipe with a basic redstone engine? The wooden transport pipe when powered "sucks" items out of things.


Does don't connect to RP machines, do they?
---
Official Lopunny of the Black 2 Board
#4WhiteRabbitKizi(Topic Creator)Posted 6/11/2012 12:18:40 AM
Ah, tried that as well. It does work on chests and anything that mimics a chest such as a RP Relay. Sorting still won't work with it though >_> It's really pissing me off cause I duplicated it like 100 blocks away and it works perfectly... it's just this one damn spot that won't work... thing is, the one spot is inside a massive 70 block tall sorting complex that has four floors and an extremely complicated and intricate setup that automatically extracts blocks from a mobile drilling platform by docking... Something I'd rather not duplicate...
---
GT: WhiteRabbitKizi
#5ineedaname88Posted 6/11/2012 2:57:26 AM
If it was working before, what was changed?
---
Go big or go home broke. Bro-ski.
PSN: ThereIsNoSanta88
#6benjaminkcPosted 6/11/2012 12:00:22 PM
Is it possible for a chunk to just have too many tile entities, that some of them stop working? Given the size of the setup you describe, maybe that is what has happened. That's just a wild guess though, I have no idea if that is a real thing that happens.
#7zeldalordPosted 6/12/2012 10:05:58 AM(edited)
EDIT: Have you tried looking into restructuring it to use diamond transport pipes (which can filter) and iron transport pipes (for flow control, they are one way pipes) each of these can be configured and they might work better. In my opinion and in my own research RP seems to be really buggy and in efficient on tekkit. I mainly use it for cosmetics and when i need my wires not tangling.
---
XBL - Gamertag: Zeldalord
"Gravitation is not responsible for people falling in love." - Albert Einstein.
#8WhiteRabbitKizi(Topic Creator)Posted 6/12/2012 8:42:29 PM
Thanks for all the replies. I found out what the problem was. The way the facility is set up the chest access is below the actual sorting on each level. I had RP lamps in the ceiling and when the lights were turned on, it powered the sorting machine, hence stopping it. Never noticed because the lights are automatic and I didn't realize they were on lol >_>
---
GT: WhiteRabbitKizi