Minecraft Forge doesn't seem to work.

#1tomandsamPosted 8/27/2012 5:32:13 PM
A google search didn't give me any answers, so that's out of the question.

I recently decided to use Minecraft Forge instead of ModLoader, to open up more mod compatibilities, but it doesn't work correctly. With Forge installed, anytime a Mob takes damage, it instantly disconnects me, saying "Internal Server Error." If a mob is taking continuous damage, such as from lava, I can't load the world anymore, just getting a crash report referencing lava and the entity being damaged. Switching back to ModLoader fixes everything, so I'm relatively sure it's a Forge issue.

Currently, I am installing mods in this order:
1. Forge
2. Optifine

I have Rei's Minimap in the "mods" folder, but that's all I'm using. I made sure Optifine was installed last. I tried Forge again, but it still didn't work. I can't figure out why this would happen, but hopefully someone here can?
---
This is quite possibly the worst user on GameFAQs:
http://www.gamefaqs.com/boards/user.php?=2426382
#2Zarren364Posted 8/27/2012 5:54:13 PM
It might just be a temporary fix, but switch to Peaceful from the main menu. At least if it's a hostile it might despawn before it loads anything. Otherwise I don't know what to tell you. Delete the bin, redownload, reinstall and hope.
---
GLAD GANG l SSS l No.XII l OPBW2C-Wargle I R - Zarren
I am the Anti-troll. Your poll needs a bacon option.
#3ineedaname88Posted 8/27/2012 6:04:52 PM
Are you using the recommended version of forge? And Reis is now a mods folder mod?
---
Go big or go home broke. Bro-ski.
#4tomandsam(Topic Creator)Posted 8/27/2012 6:24:51 PM(edited)
Yes, I'm using the recommended build of Forge, not the developmental. Rei's Minimap is in the mods folder, but removing it didn't help at all, so it's not an issue with that.

The mob in question is a chicken, so Peaceful won't help. I don't really care about that world. I just made it as a test.

EDIT: Using ModLoader instead allows me to load all my worlds fine.
---
This is quite possibly the worst user on GameFAQs:
http://www.gamefaqs.com/boards/user.php?=2426382
#5tomandsam(Topic Creator)Posted 8/27/2012 8:55:51 PM
I suppose I'll just have to deal with no Forge, then. That's quite a bit of lost mods, huh.
---
This is quite possibly the worst user on GameFAQs:
http://www.gamefaqs.com/boards/user.php?=2426382