Alduin not taking damage? *spoilers?*

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.
  1. Boards
  2. The Elder Scrolls V: Skyrim
  3. Alduin not taking damage? *spoilers?*

User Info: amitydrive

amitydrive
5 years ago#1
So I'm fighting him on top of the Throat of the World in the Alduins Bain quest, and no matter how much I hit him, his health is not going down at all. And yes I'm using Dragonren on him. Is this a glitch, and how do I fix it?

User Info: PinkiexPie

PinkiexPie
5 years ago#2
Its a glitch, yes, Ive encountered it myself, just reload your latest autosave until it fixes. Perhaps try turning your xbox on and off.
Pinkie Pie is best pony

User Info: amitydrive

amitydrive
5 years ago#3
Ok o will try that. Though at first he just had a stupid amount of health.

User Info: DrakoVongola1

DrakoVongola1
5 years ago#4
Have fun, that is a hard fight.

Just try not to hit Paar when you use Dragonrend.
I believe in Jesus, the son of God, the one way to salvation.
11/11/11: The day everyone lost their social lives

User Info: anomielemma

anomielemma
5 years ago#5
had this happen. after 10 minutes of smacking him i sheathed my weapon and tried talking to him. then it continued normally. might work if your stuck.

User Info: amitydrive

amitydrive
5 years ago#6
Ok, reading worked. Thanks.

User Info: amitydrive

amitydrive
5 years ago#7
Reloading I meant. Fight was fairly easy.
  1. Boards
  2. The Elder Scrolls V: Skyrim
  3. Alduin not taking damage? *spoilers?*

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived