Shouts not working glitch?

#1scorpio manPosted 11/17/2011 1:16:19 PM
Does anyone have a glitch were sometimes when you go to use a power, the ability refuses to activate in battle?

Iam using the basic first force push shout, used it once in battle and I have the amulet of talos, the cool down is beyond over and I try to use it again and simply nothing happens, I mash on RB and eventually later in the battle when I try again it will work.

This isnt all the time and no I know how to read the cooldown meter, its not that.
---
Cast in the name of God, ye not guilty.
Xbox Live Gamer Tag - Polak Toma
#2scorpio man(Topic Creator)Posted 11/17/2011 1:32:43 PM
bump..
---
Cast in the name of God, ye not guilty.
Xbox Live Gamer Tag - Polak Toma
#3GermanottaPosted 11/17/2011 1:34:16 PM
Happens to me sometimes too. I'm not entirely sure why.

My guess is that the animation for your previous action may not had ended yet, or you get disrupted in some other way.
---
And then I become greeeeeen like the hulk and I
feast off the flesh of the haters.
#4appleturnover87Posted 11/17/2011 1:35:29 PM
happens to me sometimes to. if you sheath your weapon the shout will come out right as you do so
---
What's love got to do, got to do with it?
#5Errl_SapsonPosted 11/17/2011 1:36:00 PM
yeah its really really annoying
#6scorpio man(Topic Creator)Posted 11/17/2011 1:36:33 PM
Ugh thanks I thought I was the only one! XD

I hope they patch this its soooo annoying
---
Cast in the name of God, ye not guilty.
Xbox Live Gamer Tag - Polak Toma
#7MmaguyPosted 11/17/2011 1:37:02 PM

Very annoying, yes.

#8gianokoupolosPosted 11/17/2011 1:47:56 PM
Happens to me. Thinking I'm about to shout only to have nothing happen and take a mauling to the face by a troll I pissed off isn't exactly brilliant...