Invincible Alduin...

  • Topic Archived
You're browsing the GameFAQs Message Boards as a guest. Sign Up for free (or Log In if you already have an account) to be able to post messages, change how messages are displayed, and view media in posts.

User Info: Link_2666

Link_2666
3 years ago#1
I've really been having trouble with this glitch. It's for the first battle with Alduin. I get everything prepared to fight him and then he doesn't take any damage. Everywhere says to wait until he stops talking to use Dragonrend but even that doesn't seem to be working. I've even tried reloading an earlier save. It worked once but then I died anyway and it's glitched every time since.
PSN: ShadowShockX. XBL: Ace0fSpades52
Currently playing: Skyrim (X360), Mass Effect (PS3)

User Info: kgood0521

kgood0521
3 years ago#2
This happened to me in both of my playthroughs. I loaded my save right before reading the elder scroll and then i wait and dont attack or dragonrend until alduin comes down to attack the first time.
XBL: KGdlux0521 / PSN: K_GooD_5 / 3DS: 2191-7651- 4963

User Info: jammymacster

jammymacster
3 years ago#3
Restart your 360. Load up a save from before you started fighting him. Wait for him to finish talking and attack. Then proceed with the fight as normal. Should work.
AKA: Valadez

User Info: Link_2666

Link_2666
3 years ago#4
Thankfully I was able to beat him. I appreciate the help guys. I did a combination of everything. I even cleared the cache memory on my console. And for good measure I put on a necklace of waning magic and a ring that boosts my health by 40, as well as the mercenary from the bar in solitude (stocked up with some nice Orc armor, I might add). He dropped like a rock after 4 or 5 assaults.
PSN: ShadowShockX. XBL: Ace0fSpades52
Currently playing: Skyrim (X360), Mass Effect (PS3)

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived