For those complaining about blocky shadows, I have a fix that is great!

#1Lucavi000Posted 11/12/2011 2:23:10 AM
I have a few screens that will prove beyond a doubt that the shadows in Skyrim can look 100%, nay, 200% better than what they can on Ultra.

For the record I'm running skyrim at 1920x1080 full ultra with no AA or AS but with FXAA on and shadows on Medium. I can run them on ultra but they look just as crappy as medium until I did this:

All you have to do is go into your (win 7) documents\mygames\skyrim\ directory and open SkyrimPrefs with notepad. Youll get a giant screen of information but don't be afraid because the screen shots show you exactly what to change and what to change them to. Please remember that my shadows before and after the edit are on medium. Youll be amazed at the change and I'm sure theyll look even better on Ultra though I didnt test it.

Here is the default settings on medium:

http://i.imgur.com/4MHuh.jpg

Note those shadows around the turn wheel, the cart and the wooden structure to its left. Garbage...look at those jagged edges. Looks like an atari 2600 took a **** on the ground. Look at my Argonians shadow; looks like a bunch of stacked tetris blocks. It's terrible right? Right. You'll notice on the left my default SkyrimPrefs file with red boxes around the shadow settings. We'll change those in a minute.

Here is an after picture with the modified changes. Still on medium shadows mind you:

http://i.imgur.com/4LirV.jpg

What's madness is this!? Round shadows in MY Skyrim!? Perish the thought! That cart...the shadow actually looks like a cart and not a jagged mess of ridiculous. That chickens shadow isnt a square. Look at my Argonians tail shadow. Yes, youre not delusional...those are individual tail spike shadows. You'll see on the left the modified changes to the shadow numbers. Just changed them all to 4096 and save. Start up Skyrim and go to town.

TLDR; Look at pics, read where to find file, make changes, get happy.
---
oh great... why would they do that? I'm a nerd, that's the exact kind of thing I like to avoid... maybe I'll just buy it during the day -Sahuagin
#2Matriarch ProtectorPosted 11/12/2011 2:25:33 AM
What is the performance hit on that fix.
---
sig.
#3Lucavi000(Topic Creator)Posted 11/12/2011 2:26:29 AM

From: Matriarch Protector | #002
What is the performance hit on that fix.


none so far. 60 fps running around skyrim and 40+ in bustling towns. What it was before I did anything.
---
oh great... why would they do that? I'm a nerd, that's the exact kind of thing I like to avoid... maybe I'll just buy it during the day -Sahuagin
#4dnd22Posted 11/12/2011 2:28:36 AM
And for "shaking" or "twitching" shadows, set

iBlurDeferredShadowMask=0
iShadowMaskQuarter=0

in the same file.

Worked for me at least, ymmv.
#5Lucavi000(Topic Creator)Posted 11/12/2011 2:29:09 AM

From: dnd22 | #004
And for "shaking" or "twitching" shadows, set

iBlurDeferredShadowMask=0
iShadowMaskQuarter=0

in the same file.

Worked for me at least, ymmv.


Good addition. I havent really noticed those particular symptoms but I'll keep those fixes in mind if I do.
---
oh great... why would they do that? I'm a nerd, that's the exact kind of thing I like to avoid... maybe I'll just buy it during the day -Sahuagin
#6schesakPosted 11/12/2011 2:30:27 AM
Those are the settings changed when you increase shadow quality in options, so you really aren't at medium shadows anymore.
#7Lucavi000(Topic Creator)Posted 11/12/2011 2:35:40 AM(edited)

From: schesak | #006
Those are the settings changed when you increase shadow quality in options, so you really aren't at medium shadows anymore.


no sir.

SS of Ultra default shadows.

http://i.imgur.com/T8iA0.jpg

note from my default medium pic; the ultra shadows arent QUITE as blocky but still blocky as hell. Changing the numbers like I did in the ini has a tremendous impact on the shadow edges. 1024/2048/1024 are stock across all 4 shadow settings. the only number that changes is the shadow quality number. ultra = 4.
---
oh great... why would they do that? I'm a nerd, that's the exact kind of thing I like to avoid... maybe I'll just buy it during the day -Sahuagin
#8AtSeNPosted 11/12/2011 2:50:08 AM
dnd22 posted...
And for "shaking" or "twitching" shadows, set

iBlurDeferredShadowMask=0
iShadowMaskQuarter=0

in the same file.

Worked for me at least, ymmv.


Great fix, but changing iShadowMaskQuarter is a bad idea unless you don't care about having no indoor lighting.
---
When will I see you again?
#9Chubbers64Posted 11/12/2011 2:52:19 AM
Causes the game to crash when loading a save for me
---
:D
#10schesakPosted 11/12/2011 2:53:24 AM
Lucavi000 posted...
From: schesak | #006
Those are the settings changed when you increase shadow quality in options, so you really aren't at medium shadows anymore.
no sir.

SS of Ultra default shadows.

http://i.imgur.com/T8iA0.jpg

note from my default medium pic; the ultra shadows arent QUITE as blocky but still blocky as hell. Changing the numbers like I did in the ini has a tremendous impact on the shadow edges. 1024/2048/1024 are stock across all 4 shadow settings. the only number that changes is the shadow quality number. ultra = 4.


Are you sure about that? because in my ini file the numbers were all already at 4096 except for one of them which was at 2048.