Soul Sacrifice Required Firmware?

#1ThamauturgePosted 4/30/2013 4:28:08 AM
I was wondering, what is the required firmware for Soul Sacrifice? Can you play it on 2.02?
---
Official Wiegraf Folles of the FFXV board
Playing: SH2 HD, Dark Souls, Uncharted 2, Crisis Core: FF7, Ratchet Collection, REmake ------- PSN: Thamauturge
#2Golden_MeanPosted 4/30/2013 4:30:31 AM
You can probably play it on any version but to play online you must have the most recent update(s).
---
LoL: Rontuaru -- PSN: Kikkosauce66 -- SoulSacrifice: Rontu
#3RotuhiiriPosted 4/30/2013 4:32:19 AM
Are there any games that require a certain firmware to play on the Vita?

I know online always requires the latest mandatory firmware but I don't think any games require a certain firmware for offline play.
---
JRPG fans, support our struggle: http://chn.ge/SsowWy
Like our cause: https://www.facebook.com/OperationDemonBane
#4akshat_316Posted 4/30/2013 4:43:47 AM
Rotuhiiri posted...
Are there any games that require a certain firmware to play on the Vita?

I know online always requires the latest mandatory firmware but I don't think any games require a certain firmware for offline play.


I did on the psp.So maybe it is the same on the vita.
---
www.staticshin.com
#5jmtstanPosted 4/30/2013 6:29:54 AM
update the firmware?
---
New Vita owner!!!
PSN: jmtstan1138
#6WooTz_samaPosted 4/30/2013 7:27:41 AM(edited)
Either ditch your "homebrews" and upgrade to latest exploit patched firmware, or buy another Vita.

Soul Sacrifice is meant to be enjoyed online.

It's that simple.
---
US PSN: FUS-RO-DAAH | JP PSN: WooTzZ-vita
Now Playing: Soul Sacrifice, Persona 4 Arena, Tomb Raider, Resident Evil 6, GTA IV
#7Thamauturge(Topic Creator)Posted 5/1/2013 4:12:08 PM
[This message was deleted at the request of a moderator or administrator]
#8Eternal_StrikePosted 5/1/2013 5:35:27 PM
Thamauturge posted...
From: jmtstan | #005
update the firmware?


And lose Crisis Core, Kingdom Hearts BBS, games I already own on UMD and wont have to buy again, Homebrews, and the FFType-0 English Patch? How about no.

Anyways, wololo confirmed that SS requires 2.05 even for offline. Unfortunate, but expected.


just acquired your ip address now i know where you are, im telling sony
#9WerzaquePosted 5/1/2013 5:40:14 PM
Thamauturge posted...
From: jmtstan | #005
update the firmware?


And lose Crisis Core, Kingdom Hearts BBS, games I already own on UMD and wont have to buy again, Homebrews, and the FFType-0 English Patch? How about no.

Anyways, wololo confirmed that SS requires 2.05 even for offline. Unfortunate, but expected.


Ah, what a hero! Proud to be meddling in illegal activities! Your peers must be so proud of you!
---
You are ignoring 167 message(s) from users on this page. Manage your list here.
#10alphame4Posted 5/1/2013 6:00:24 PM
Thamauturge posted...
From: jmtstan | #005
update the firmware?


And lose Crisis Core, Kingdom Hearts BBS, games I already own on UMD and wont have to buy again, Homebrews, and the FFType-0 English Patch? How about no.

Anyways, wololo confirmed that SS requires 2.05 even for offline. Unfortunate, but expected.


So basically you just want to keep playing PSP isos on your vita?
---
Steam: Spacerik | PSN: Spacemooncow | Wii U: the-fiend | 3DS: 4296 - 2991 - 9745 | Battle.net: RoboWalrus | XBL: cannon fodderr