Lexington Items glitch

#1Dominator24246Posted 2/2/2013 3:55:23 PM
So I have all of the other delivery missions done except for this one. Whenever I go up to the quest giver, it lets me accept it like normal. However it never shows the list of items I neec to get, and if I leave and come back, the quest giver offers me the quest as though I'd never accepted it. Anyone know of a fix?
---
Black FC: 3869-6873-5044
Black 2 FC: 0090-1207-6707
#2divot1338Posted 2/2/2013 8:46:23 PM
http://m.gamefaqs.com/xbox360/621797-assassins-creed-iii/faqs/65196?page=1#section100
---
Xbox GT: AGE Sam Sneak
#3cowboybbp1Posted 2/4/2013 5:12:54 PM
This has happened to me a lot with several different missions. What I did was fast travel to an area somewhat far away from the mission, then walk my way to the mission. it seems to give the game enough time to register whatever it needs to to accept it properly. try that a few times, I know that it will eventually work. good luck.
---
Gamertag: Porta de Verum
PSN: cowboybbp1
#4SLucky23Posted 2/5/2013 10:36:54 AM
I also just stood there next to the guy for about two minutes before actually initiating the mission. I believe I tried this on my sixth or seventh try, and it finally worked. Maybe give that a try. What a pain in the *** those delivery requests were.
More topics from this board...
Nine men's morris problemNairel217/21 5:23AM