My God.

#11mrNicknamePosted 12/9/2012 1:49:40 AM
http://www.geforce.com/Active/en_US/shared/images/articles/nvidia-geforce-310-70-drivers/nvidia-geforce-310-70-drivers-far-cry-3-performance.png

^ Hmmmm...
---
AMD i386 100MHz, 8MB RAM, Generic VGA graphic, play pong at 60fps
#12overkillwfo1978(Topic Creator)Posted 12/9/2012 2:23:17 AM
Well, now it seems to be working a little better. 50-60 fps with MSAA at 2 and everything on very high/ high. Its a good looking game so far, I'm having fun with it...
---
"Everything is bad about the console. It can't play Rugged Stubble Hero 4: Revenge of the guns" -MotiJR on the Wii U
#13BlackMantisPosted 12/9/2012 2:39:50 AM
Weird. I have it set at everything max, except for MSAA at 4, and the game is very playable for me. I can tell there's a small difference in framerate sometimes but nothing that comes close to being even slightly annoying.
---
i5-3570k | Gigabyte Z77 UDH5 | evga GTX 680 SC | 8 gb RAM | 2TB HDD | HAF 932
#14ClaptonvaughnPosted 12/9/2012 3:00:15 AM
mrNickname posted...
http://www.geforce.com/Active/en_US/shared/images/articles/nvidia-geforce-310-70-drivers/nvidia-geforce-310-70-drivers-far-cry-3-performance.png

^ Hmmmm...


Those drivers increased performance for me, too. To be fair, I didn't test extensively but there was one area where I would consistently get 45 fps, and after the patch, it stayed between 55-60.

I have everything on their highest settings except MSAA is at 2x and res is 1680x1050.

Assassin's Creed 3 causes more framerate fluctuation than this game. It'll drop to low 30s in certain parts of Boston.
#15GodXIIPosted 12/9/2012 4:20:05 AM
It's not your driver fault. We cannot play it 60FPS in Ultra etc. It's Ubisoft coding. They messed it.
---
GTX 680 | i7 3770k | ASUS P8Z77-V-LX | Ram Corsair Vengeance 16GB 1866 C10 | SSD Samsung 830 128GB | HDD 2T Seagate Barracuda 64GB 7200rpm | Windows 7 64
#16exclusiveburnerPosted 12/9/2012 7:15:32 AM
It seems like every game has a certain feature that can cause huge drops in FPS. Witcher 2 had Ubersampling, BF3 had Ultra Textures that without 8gigs of ram would kill your fps, and plenty of other games have this too. One setting to reduce or turn off that makes everything normal.
#17ArcticPosted 12/9/2012 7:27:00 AM(edited)
i7 930 4ghz
GTX 680 2GB @ 1206mhz core
12GB 1600mhz Dom GT's

1920x1200, DX11 Ultra with 2xAA = 45fps min, 60+fps average, silky smooth. Just drop the AA, force FXAA/MLAA if you don't mind the slight blurriness in exchange for a smoother frame rate. Or you could inject SMAA and see how that works.
---
Pissing excellence since 02/24/2001
#18MrXGamerPosted 12/9/2012 8:27:44 AM
I have GTX 680 4GB version and I get around 40 FPS with everything max + MSAA x4. My problem is that the game doesn't feel smooth at all, 40 FPS feels like 20. Never got this feeling from any other game. For this reason, I'll have to turn down my settings for 60 FPS and see if that makes any difference.
---
Asus Z77 Sabertooth | i7 3770k | EVGA GTX 680 Classified | Corsair Vengeance 16GB - 1600MHz | Crucial m4 SSD | Blu-ray | Win 7 x64
#19BigheadNo1Posted 12/9/2012 8:29:51 AM
GT 330M here, has yet to be eaten.

1280x768 on low, 30 fps
#20Gmoney-Posted 12/9/2012 12:16:53 PM
Just turn MSAA off. You'll run ultra with high frames.
---
The fire baby, it'll burn us both. Always....and never.