Far Cry 3 crashes when card is overclocked.

#1Pens_FanPosted 12/22/2012 1:01:05 PM
I have a GTX 570 HD. I can play the game no problem when I have my card set to default settings but when I overclock my card the game will crash on me. I have the voltage set to 1075. The GPU clock set to 900 MHz. Memory clock set to 2000 MHz. The temp stays aroud 60-70 degrees while I'm playing. I can play any other game no problem with these settings. I have ran the Heaven benchmark with no problem with everything on the highest settings. I just don't know whats going on. I have the newest beta drivers installed.
#2Zerol09Posted 12/22/2012 3:36:44 PM
Some games are particular "sensitive" to OCed settings because when you OC you card or any of the hardware in general you actually modifying the value on how it performed in which the software or any of your program anticipated.

Just the other day I keep encountering crashes in XCOM: Enemy Unknown and after downclcoking my OCed card a little things went smooth all the way. So I would say if you want to play games just the way it was programmed to play then just switch back to the default settings and value and OC back only when you want to do any benchmark or stuff like that.
#3STG DeathbotPosted 12/22/2012 5:43:49 PM
You can overclock any of your hardware and have it work perfectly fine for years and then one random game will crash because of the overclocks. Like the previous poster said, games are very sensitive to overclocking. Every game runs perfectly fine on my overclocks except for Medieval 2 Total War. It crashes when I try to start a 1,000+ vs 1,000+ battle.
---
Intel Core i7-3770K Ivy Bridge 4.5GHz | 8GB Samsung RAM DDR3 1600 (11-11-11-28) | SLi eVGA GTX 670 4GB VRAM 1006/1084/6008 | ASUS 27" Monitor @ 2560X1440
#4SoldierXCellPosted 12/22/2012 8:21:20 PM
Try playing Multiplayer,.
#5Syco ClownPosted 12/23/2012 8:45:58 PM
Try it at 850mhz. I have the same issue with my GTX 560 TI and BF3, so I just get Afterburner to underclock the card to 850mhz core clock and 2000mhz memory clock. Never crashes with these setting for me.

Good luck with it.
---
Obscure Creations