Spartan ops episode 8 chapter 4 crystal ball glitch?

#1WodPythonPosted 2/9/2013 8:16:34 PM
Am I the only one getting this glitch? Basically, near the end of the level where the 2 phantoms and one drop pod arrives, you are asked to kill the remaining enemies which are marked (just before releasing those locks, with the hunters).

Sometimes I've encountered this glitch where it would show an enemy marker in the sky, this weird bright spot (which I am positive it's the second phantom trying to leave the area after it drops off the two ghosts and other enemies), and of course I can't progress through the level until all the enemies are dead.

I've tried killing it (ie. fuel rod cannon or ghost fire), but most of my shots go right through the bright spot. I haven't found that anyone else has discovered this. I'm curious if any has encountered this glitch or a similar one in this level (or any other levels for that matter), and if there is a way to get by it, other than having to start over the level.

As a disclaimer, this was done on solo.
---
"Those who would sacrifice liberty for security, deserve neither."
#2Demigod_ElessarPosted 2/9/2013 8:45:18 PM
I did not have a problem with that particular level, but I have experienced the same situation two different times in the past.

The first was on a mission back in episode 1, where an enemy Watcher got "stuck" in a pillar and there was NOTHING I could do to damage/kill it. I tried shooting it, throwing grenades, trying rocket launcher/scattershot blasts, nothing worked.

Happened again one a mission in episode 7 as well. Same situation. An enemy (this time a Knight) got "stuck" in a wall. And once again, there was nothing I could do to destroy it. Both times I had to restart the level (an annoyance when you play on Legendary, solo).

Sounds like you may be having the same situation, just your opponent is showing up in the sky? If that is the case, I don't think there's anything you can do but just restart the mission.
---
IRON MAIDEN IS MY RELIGION!
Gamertag: Demigod Elessar
#3WodPython(Topic Creator)Posted 2/9/2013 8:51:02 PM
Not so much "showing up", it already showed up, in the form of a phantom dropping off 2 ghosts, plus more guys, then it would fly away like normal, however it would eventually compress into this weird ball of light, and it would be counted as an enemy that I would eventually have to kill to have access to unlock the locks.
---
"Those who would sacrifice liberty for security, deserve neither."
#4FL0YD_theBarberPosted 2/9/2013 8:52:25 PM
Yes, this exact thing happened to my group. Had to quit & start over. These type of glitches only happen to me in co-op, never solo.
#5WodPython(Topic Creator)Posted 2/9/2013 8:59:43 PM
Well I was actually playing solo, I'm starting to think 343 does a terrible job of testing (assuming they test at all).
---
"Those who would sacrifice liberty for security, deserve neither."
#6FL0YD_theBarberPosted 2/9/2013 9:08:42 PM
It's not just 343. Most games I buy now, I feel like I payed to be a beta tester. The games usually get fixed after I am done with it. It's a shame developers feel it is ok to release a broken game, and try to fix it later or not at all.
#7WodPython(Topic Creator)Posted 2/10/2013 8:11:00 AM
I'll say this, in their defense, the main Masterchief campaign was awesome =).

O"n topic, I've actually discovered the said-glitch appears to happen when you kill both grunt gunners on the 2 side turrets.
---
"Those who would sacrifice liberty for security, deserve neither."