Tip for extra fps for those who are 'cpu bound'

#1HeyZeussPosted 12/4/2012 1:01:22 AM
Try setting the priority of planetside2.exe in task manager to 'High' (NOT realtime).
I seem to get at least 5-15 extra fps in large battles, and a little more in empty areas.

Phenom II x4 905e
gtx 560ti

Went from 10-15 fps in big battles to 20-30 at least. Usually around ~25, which I'm pretty much ok with at this point. (Huge improvement over 10).
And I get 60 in empty areas.\

Hope this helps!
#20cu_87Posted 12/4/2012 1:27:32 AM(edited)
My recommendation for a mid-setup is to turn shadows off. Set shadowquality to 0 in useroptions.ini. That doubled my FPS. Too bad some areas look cartoony and unrealistic now.

If you have to upgrade your rig, buy some new RAM. DDR3 is really cheap at the moment. I got 8GB of 1600 MHz Corsair DDR3 RAM for 40 bucks.
#3Gods_HandPosted 12/4/2012 1:32:30 AM
Above normal is all you need, anything more is not only unnecessary it might cause problems, although not likely unless set to real-time, don't do that ever.
#4HeyZeuss(Topic Creator)Posted 12/4/2012 8:07:04 AM(edited)
Well, for people like me who really are cpu bound, the settings won't actually matter. I get almost the exact same fps running all maxed settings @ 1920x1080 as I do with everything set to the minimum @1024x768. Actually, in some cases I actually get MORE fps maxed it seems. It's because my gpu can handle whatever the game is throwing at it, while my cpu can not, so it's bottlenecked there. This little tip just helps prioritize cpu usage a bit I guess, so it's not wasting energy on other things.

(I do set shadows to medium though, just for a little extra boost )

And yes, I stressed NOT realtime, as that will guarantee problems ;)
#50cu_87Posted 12/4/2012 10:42:49 AM
My game instantly crashed with the new update and priority set to "Above normal"
#6ghrrcPosted 12/4/2012 1:17:45 PM
HeyZeuss posted...
Well, for people like me who really are cpu bound, the settings won't actually matter. I get almost the exact same fps running all maxed settings @ 1920x1080 as I do with everything set to the minimum @1024x768. Actually, in some cases I actually get MORE fps maxed it seems. It's because my gpu can handle whatever the game is throwing at it, while my cpu can not, so it's bottlenecked there. This little tip just helps prioritize cpu usage a bit I guess, so it's not wasting energy on other things.

(I do set shadows to medium though, just for a little extra boost )

And yes, I stressed NOT realtime, as that will guarantee problems ;)


Lower your shadows or turn them off completely and set the render distance to 1500 - 2500 (mine is currently @ 1800 with a 960T@3.4ghz) in the UserOptions.ini file, as you go lower more of the map gets covered in fog at a distance. This will have a major impact on performance, much more than changing CPU priority will (do that as well if it helps).
---
http://www.youtube.com/user/ghrrc6