Windows 7 compatability issues (rainbow colour glitch)

#1AnDtuigeannTuPosted 2/18/2010 7:47:37 AM
Ok, before I start I just wanna say ive done the searching and I read the sticky. I have tried compatability mode from windows 98 to xp(sp3) (it works on my old xp sp3 machine) and I cannot get rid of this rainbow glitch. 256 colours just makes the problem worse(even more shades are affected). I tried patching it but the latest patch I can find wont run on windows 7 64bit home premium and the old HD patch isnt up for download anymore (any other resolution patches wont work on vanilla f2).

So anyone else have this problem and fixed it?

---
Gt: AnDtuigeannTu
#2CutterDeBlancPosted 2/18/2010 9:25:30 AM
I dunno if I had the same problem as you exactly, but my graphics would bug out and i'd alt+tab out and then it usually was fixed after that.

...Or you could try running it in windowed mode, it never seems to give me that weird graphical glitch when i do that, only in fullscreen.

---
No habla espaņol.
#3red255Posted 2/18/2010 10:07:02 AM
I think it was a graphics card driver error.
It went away when I updated my card's drivers I think.

Or reinstalled. did alot of things and it went away.
---
If the next one is called, because of his MO, the underwear bomber, you'll know I'm on to something. Calvin Trillin June 16, 2006.
#4AnDtuigeannTu(Topic Creator)Posted 2/18/2010 4:08:50 PM
Both you guys have been running it on win7 64bit?

---
Gt: AnDtuigeannTu
#5jon2jonPosted 2/18/2010 8:35:02 PM

while i haven't played this game yet, (planning on getting it soon) this happened to me with diablo ii. i looked online and found out that if you open up screen resolution by right clicking the desktop, and then leaving it running in the background while playing, it gets rid of the rainbow colors. don't ask me why it works, but it fixed my problem with diablo ii and its worth a try.

#6jon2jonPosted 2/18/2010 8:35:23 PM

oh yeah and i'm running win7 64

#7AnDtuigeannTu(Topic Creator)Posted 2/20/2010 1:39:10 PM
Yeah, the resolution window fix actually works lol, cheers a whole bunch man

---
Gt: AnDtuigeannTu
#8GranbarPosted 2/22/2010 11:46:15 AM
Turn off your SLI or CrossFire.
---
Don't smoke kids! Unless you're on fire, then it's only natural.
#9YstPosted 2/23/2010 5:28:57 PM
MS included Virtual PC free starting with Windows Vista for a reason.

I mean, really. I can't imagine why anyone would bother struggling to run Fallout 2 under Windows 7 natively when Microsoft provides a VM created specifically to support prior Windows versions, and provides it at no cost to the user, with regular updates.
#10LucientPosted 2/25/2010 9:22:22 AM
Download the high res patch for Fallout 2, then go in the preferences and change the color mode to 16 bit. That will fix it. I had the same problem (using 7 32 bit), doing that fixed it.