Enable PhysX On AMD/ATI Cards

#1F_WolfPosted 9/18/2012 5:18:45 AM(edited)
C:\Users\USERNAME\Documents\My Games\Borderlands 2\WillowGame\Config\WillowEngine.ini


Search for:

PhysXLevel

Change

PhysXLevel=0 <- (low)

to either:

PhysXLevel=1 <- (mid)

or

PhysXLevel=2 <- (high)


Works just fine with no issues for me. I have a 6950 flashed and overclocked to a 6970, no frame drop whatsoever, and all my flapping flags/water things are now showing up in the game and can be manipulated.
#2LottoStudPosted 9/18/2012 5:13:42 AM
Tag thanks
---
Two shots of whatever
#3F_Wolf(Topic Creator)Posted 9/18/2012 5:18:13 AM
LottoStud posted...
Tag thanks


Yeah, I thought most people would be interested. Like always, PhysX effects don't actually need a PhysX card at all. Gearbox just has a software limiter that prevents you from turning it on in the menu unless you have one. Simple ini tweak and there you go, PhysX on any card.

Of course, I wouldn't go enabling it on like, a 4XXX series AMD or anything, but play around with it, chances are most people can at lest run it on medium if you can already max the other settings.
#4Glockass1Posted 9/18/2012 5:18:26 AM
Ok do you want babies now or later?
---
Steam ID: Glockass1
#5F_Wolf(Topic Creator)Posted 9/18/2012 5:26:44 AM
Hehe, the easiest way to tell if this is working is that all the mobs will leave PhysX enabled blood puddles behind if it's on.
#6SpacedDuckPosted 9/18/2012 5:30:17 AM
So hold on a second. I went into my game and went and tweaked the graphics before I played. Everything was defaulted to High and Physx was set to Low.

I turned it up to medium and saved and rebooted the game.

When I play and shot the ground, rocks fly up and look awesome, when I shoot dead bodies blood squirts out and runs down hills etc.

Does that mean my card is compatible with Physx?

I have an HD 7850 2GB card.

The framerate is holding up pretty well. The rocks that fly up fall semi slow but other than that game seems good. Wish there was a way to see what my FPS were.
---

Keep/Kept the Faith! Forever a member of Red Sox Nation!
#7Glockass1Posted 9/18/2012 5:31:27 AM
SpacedDuck posted...
So hold on a second. I went into my game and went and tweaked the graphics before I played. Everything was defaulted to High and Physx was set to Low.

I turned it up to medium and saved and rebooted the game.

When I play and shot the ground, rocks fly up and look awesome, when I shoot dead bodies blood squirts out and runs down hills etc.

Does that mean my card is compatible with Physx?

I have an HD 7850 2GB card.

The framerate is holding up pretty well. The rocks that fly up fall semi slow but other than that game seems good. Wish there was a way to see what my FPS were.


http://www.fraps.com/
---
Steam ID: Glockass1
#8LordPonchoPosted 9/18/2012 5:36:18 AM
F_Wolf posted...
LottoStud posted...
Tag thanks


Yeah, I thought most people would be interested. Like always, PhysX effects don't actually need a PhysX card at all. Gearbox just has a software limiter that prevents you from turning it on in the menu unless you have one. Simple ini tweak and there you go, PhysX on any card.

Of course, I wouldn't go enabling it on like, a 4XXX series AMD or anything, but play around with it, chances are most people can at lest run it on medium if you can already max the other settings.


It's not Gearbox doing that, it's cuz Nvidia owns the physx technology (which is powered by CUDA)

The game is so relaxed on resources that enabling physx on an ATI card works just fine.
---
"lol der was a shdow on my carpet but ti looked like a stane and tried to clen it up but ti was a shadoow" -Ghost4800
#9F_Wolf(Topic Creator)Posted 9/18/2012 5:45:30 AM
LordPoncho posted...
F_Wolf posted...
LottoStud posted...
Tag thanks


Yeah, I thought most people would be interested. Like always, PhysX effects don't actually need a PhysX card at all. Gearbox just has a software limiter that prevents you from turning it on in the menu unless you have one. Simple ini tweak and there you go, PhysX on any card.

Of course, I wouldn't go enabling it on like, a 4XXX series AMD or anything, but play around with it, chances are most people can at lest run it on medium if you can already max the other settings.


It's not Gearbox doing that, it's cuz Nvidia owns the physx technology (which is powered by CUDA)

The game is so relaxed on resources that enabling physx on an ATI card works just fine.


There are plenty of other games out there that have PhysX options that can be enabled regardless of cards right in the menu. Nvidia didn't program the menu, gearbox did. I'm sure Nvidia had a hand in the decision, but ultimately it was Gearboxes choice.
#10SpacedDuckPosted 9/18/2012 5:47:52 AM
Glockass1 posted...
SpacedDuck posted...
So hold on a second. I went into my game and went and tweaked the graphics before I played. Everything was defaulted to High and Physx was set to Low.

I turned it up to medium and saved and rebooted the game.

When I play and shot the ground, rocks fly up and look awesome, when I shoot dead bodies blood squirts out and runs down hills etc.

Does that mean my card is compatible with Physx?

I have an HD 7850 2GB card.

The framerate is holding up pretty well. The rocks that fly up fall semi slow but other than that game seems good. Wish there was a way to see what my FPS were.


http://www.fraps.com/


Cool, thanks.

Looks like I'm getting about 30-50 fps with everything on high and then Physx at Medium. I'm also set to 1920x1200 for my resolution.

It does get a bit choppy though when there's a lot of enemies on screen.

Am I better off lowering the Physx to Low or lowering some settings like view distance etc to High instead of very high?

I'm running this PC

Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz

AMD HD 7850 2GB

6 Gigs of ram

Windows 7
---

Keep/Kept the Faith! Forever a member of Red Sox Nation!