choppy framerate. help with Graphics decision.

#1Rexanator64Posted 9/22/2012 2:22:02 PM
Greetings everyone.
I recently got BL2 and I decided to bump it up to max graphics settings. I'm able to run skyrim and ME3 on max settings so I figured I could run BL2 like this also.

But Whenever I get into an engagement with multiple enemies, My framerate drops significantly.
Could anyone tell me the best settings to get the best performance out of my game with my current graphics card?
Radeon HD 5800 series.
Intel core I7 CPU
930 @ 2.90 GHZ 2.80 GHz
64 bit operating system.
6GB of RAM.

Thank you for the help, Hope I've put everything needed. I'm not savvy I'm afraid.
psn:REXX_ANATOR_01 sub accnt:DELTA1-5-5
Official MK9 Champion Of Kratos.
#2NicoGrimmPosted 9/22/2012 2:26:26 PM
Turn off Ambient Occlusion.
Next time you need me for something, just know I've more pressing things to pursue!
#3venusePosted 9/22/2012 2:48:18 PM
turn the physics to low, even on med it sucks up fps
#4potatochobitPosted 9/22/2012 2:49:55 PM(edited)
turn off OC and depth of field and phsyx low and lower AA to x8 or even x4
rules do not make justice but justice has rules -potatochobit 2012
#5ChomanPosted 9/22/2012 3:36:12 PM
Cap the number of frame rates.
Necessity is the mother of all inventions.
Money is both the seed and fruit of evil.