Sonic Generations won't recognize my gaming card

  • Topic Archived
  1. Boards
  2. Sonic Generations
  3. Sonic Generations won't recognize my gaming card
4 years ago#1

Hey guys, not sure if this is the right place to post or not, but Sonic Generations won't recognize my second graphics card.

This is on my laptop. My two cards are:
1) Intel HD Graphics Family
2) NVIDIA GeForce GT 540M

Sonic Generations, in the configuration menu, can't detect my GeForce GT card. It only shows my Intel card as the only graphics card. Now with the Intel card, I'm able to play it, but not too well. There's a bit of button delay and the frame rate isn't the best.

Considering I can play games like Battlefield 3 and Assassin's Creed just fine, it's a little annoying I can't run Sonic Generations.

Does anyone have any idea?

4 years ago#2
I have this problem also, I only have the first option also. I have a laptop with an nVidia 555GTM, and I was wondering why Sonic was running so choppy on my laptop.
---
http://rcizzle.tumblr.com/ - http://backloggery.com/RCizzle65
http://30.media.tumblr.com/tumblr_lp3di6HrVJ1qb4xnqo1_400.gif http://imgh.us/rcizzle65.png
4 years ago#3
its because of optimus
is there some kind of setting in optimus so that it'll switch graphic cards when sonic starts
4 years ago#4
It's because of the way some of those mobile cards are. I think they use some sort of hybrid mode that switches between the integrated GPU and the discrete GPU and it tends to screw up on some games (especially ones that are ports like this game). If you Google your problem you might be able to find a way to force this game to use the discrete GPU.
---
Despair - Rage - Envy - Anger - Melancholia - Sorrow.
...Dreams.
4 years ago#5
Well, I can't play it at all, so be grateful.

I hate Optimus.
4 years ago#6

I've been googling and asking around for a while.

http://forums.steamgames.com/forums/showthread.php?t=2219935

Those guys are having the exact same problem. No solutions have been found yet, but it's a place to check if anyone does.

I also learned that there's no way to turn off Optimus on a Dell XPS 15 (what I have) so I really have no idea. I've tried several things now with no luck.

4 years ago#7

I've been googling and asking around for a while.

http://forums.steamgames.com/forums/showthread.php?t=2219935

Those guys are having the exact same problem. No solutions have been found yet, but it's a place to check if anyone does.

I also learned that there's no way to turn off Optimus on a Dell XPS 15 (what I have) so I really have no idea. I've tried several things now with no luck.

4 years ago#8
Sorry, double post. But yeah, Optimus is the problem here and it sucks. For now, we can just keep on fiddling around with the settings or wait and see if anyone else finds a solution, because I doubt Sega really cares.
4 years ago#9
Also having this problem. It's relieving to know it's not my laptop.
---
Fate has no forgiveness for those who dare stand against it.
4 years ago#10
Well it's kind of a relief I guess, when I was playing the game, I was like "I thought my game was able to play Skyrim at medium and high settings, why is it choking up on a Sonic game?" But I really hope there is a fix to this soon.
---
http://rcizzle.tumblr.com/ - http://backloggery.com/RCizzle65
http://30.media.tumblr.com/tumblr_lp3di6HrVJ1qb4xnqo1_400.gif http://imgh.us/rcizzle65.png
  1. Boards
  2. Sonic Generations
  3. Sonic Generations won't recognize my gaming card

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived