New city not getting regional benefits

#1ertfertPosted 4/12/2013 2:44:06 PM
I actually havent been able to find anyone complaining about this
Im well aware the game is rife with bugs, but I was wondering if anybody knows how to fix this one, since ive searched and havent found it

So i have a new city, in the region I have every City hall module, all the science related university research, all the upgrades to mining HQ, trade HQ and petroleum HQ

yet im getting NONE of it in the new city
I figured that maybe I have to have a city hall before it takes effect, but no, that didnt help

So I went back to my high tech city for a bit and the Gen II thermal reactor research finished
When I went back to my new city, it said that that research spread to my new city, but STILL nothing else
Do I have to wait more (its been several days and about 4 hours playing the new city)?
Or am I going to have to bulldoze everything and rebuild them so they take effect in the new city?
Will that work for the university research Ive already gotten?
#2ThirdDegreePosted 4/12/2013 3:20:35 PM
There are a couple things that say it requires them in a region and they still don't work. Every time I start a new city it says I have a consumer electronics division in my region so I can build a tv plant but I never can. Same goes with a few other things.
---
gamertag: HndrdDollarBaby
PSN: HundrdDollarBaby
#3ertfert(Topic Creator)Posted 4/13/2013 1:19:29 PM
ThirdDegree posted...
There are a couple things that say it requires them in a region and they still don't work. Every time I start a new city it says I have a consumer electronics division in my region so I can build a tv plant but I never can. Same goes with a few other things.


I have the same problem with the consumer electronics, but for this one city, its EVERYTHING, except the things ive gotten after i claimed the city
I tried demolishing some departments in other cities and rebuilding them, but that didnt do anything

I also tried building a second Dept. of utilities in another city, also didnt work

If theres no fix, id just like to know if anyone else has this, so I know what they might have tried to do
I still havent been able to find any other conversations of this
#4NoOneReallyCaresPosted 4/15/2013 3:13:46 PM
How big is the region in question and is your new city that isn't getting these things connected by roads to your previous cities that have these things? What connections does it have to those previous cities in the region? You should be able to check in region view. I have noticed that I do not have the ability to individually adjust taxes or take 100k bonds out in a region where I had department of finance already. And that some of the HQ stuff works anywhere in the region (or not at all).

I know that certain services and great works only work with ROAD CONNECTED cities so I am curious as to if this city that is giving you problems is road connected to your previous ones. Really the most annoying things about the bugs with this game is how inconsistent they can be.
#5ertfert(Topic Creator)Posted 4/15/2013 4:27:41 PM
Its the viridian forest region, or whatever the name is, it has 16 cities and 4 great works

even though its not supposed to matter for city hall upgrades, its connected to my 3 cities that have every upgrade, except tourism i think, by road and water
the only thing it doesnt have is a rail connection
tourism is in a separate road clump
#6NoOneReallyCaresPosted 4/15/2013 5:06:59 PM
Who knows then. Like I said I have been missing just Finance before but never everything. Sounds like a really serious region sync issue.
#7ertfert(Topic Creator)Posted 4/15/2013 5:28:17 PM
NoOneReallyCares posted...
Who knows then. Like I said I have been missing just Finance before but never everything. Sounds like a really serious region sync issue.


thanks, just glad to get some response
#8JBDevinPosted 4/15/2013 6:03:52 PM
i ran into the same problems.I suggest making room for those pre req buildings. Sucks but EA/Maxis Havent been paying much attetion
#9I Like ToastPosted 4/17/2013 6:07:30 AM
the highway road has to connect them and in rare cases there can be a 10-20 minute delay with server lag, but i haven't had that happen in weeks.
---
http://mikelikesthis.net/
MGS 5 Officially Confirmed
#10ertfert(Topic Creator)Posted 4/17/2013 9:02:22 AM
I Like Toast posted...
the highway road has to connect them and in rare cases there can be a 10-20 minute delay with server lag, but i haven't had that happen in weeks.


ive probably played about 4-5 hours in the new city and all ive gotten is the recent accomplishes ive made in my other cities, like gen II thermal reactor, yet it still says theres no department of education, university or school of science in the region (or anything else i have)