Dark Souls PC Frame-rate problems.

  • Topic Archived
  1. Boards
  2. Dark Souls: Prepare to Die Edition
  3. Dark Souls PC Frame-rate problems.

User Info: Firdeye

Firdeye
4 years ago#1
I know people have posted about getting stuck on 10-15 FPS on Dark Souls PC a lot... but I have tried literally everything.


So I have a Nvidia 670 Gigabyte, a quad core intel 6600 2.4 ghz, and 4 gigs of ram Win 32 xp, and I just started the game (in Undead Berg) at the moment, and my FPS is literally locked at 10-15, it will not budge an inch.


I have tried configuring the Nvidia control panel, turning every on highest,lowest, medium, I have tried all kinds of fixes and nothing has worked, I checked the specs and I seem to meet the recommended requirements fine. Any tips or anything will be appreciated. Thank you for your time. PS: I am running no mods, I have turned AA and motion blur off, I just have the regular Dark Souls on PC, It was running find in Firelink, AMAZING, but then I got to Undead Berg.

User Info: daredevilwlj

daredevilwlj
4 years ago#2
i am in the same boat as you. I am stuck at 15 FPS. When i am going through areas where there is nothing going on -- I will stutter in the 20s, but whenever there is action on the screen it always goes to 15 or below. I have basically given up trying to get it fixed. I have tried almost everything I can find. As long as it stays 15 or more it is very playable. However, I am a 360 "veteran" so I have alot of experience with the game. If I was a noob it may be alot harder to deal with the 15 FPS.

My laptop isn't a powerhouse but I can run Borderlands 2 30 FPS + and Guild Wars 2 at 50 FPS, so Dark Souls shouldn't be a problem.

User Info: BoswerLK

BoswerLK
4 years ago#3
for starters, you want to upgrade to win 7 64-bit. 32 bit OS's can only use around 2.8gbs of ram, so a good chunk of yours is being absolutely wasted

that said, the game is mostly cpu intensive, since it's more or less a badly made 360 emulator. it doesn't use gpu that much, and your card is pretty good, so I doubt that's your bottleneck

I'd suggest trying to optimize your cpu more for this game (closing background programs, OC'ing, etc). probably not worth all the effort just for 1 game though
My reviews: http://boswerlk.wordpress.com
"stupidity is a cure for itself"

User Info: Dex_Pyromaniac

Dex_Pyromaniac
4 years ago#4
Configure both data.exe and darksouls.exe to the following in nvidia panel

Power management mode - prefer maximum performance
Texture filtering anisotropic sample etc. - on
Texture filtering quality - performance
Texture filtering trilinear optimization - on

I did this, turned off AA and motion blur in game, and have been flawlessly running it at 30 fps ever since (with a 660 gtx laptop card so yours should handle it easily)
GT - Dex Pyromaniac

User Info: ebonystallion

ebonystallion
4 years ago#5
Dex_Pyromaniac posted...
Configure both data.exe and darksouls.exe to the following in nvidia panel

Power management mode - prefer maximum performance
Texture filtering anisotropic sample etc. - on
Texture filtering quality - performance
Texture filtering trilinear optimization - on

I did this, turned off AA and motion blur in game, and have been flawlessly running it at 30 fps ever since (with a 660 gtx laptop card so yours should handle it easily)


How would I do this on an AMD card?

User Info: BoswerLK

BoswerLK
4 years ago#6
ebonystallion posted...
Dex_Pyromaniac posted...
Configure both data.exe and darksouls.exe to the following in nvidia panel

Power management mode - prefer maximum performance
Texture filtering anisotropic sample etc. - on
Texture filtering quality - performance
Texture filtering trilinear optimization - on

I did this, turned off AA and motion blur in game, and have been flawlessly running it at 30 fps ever since (with a 660 gtx laptop card so yours should handle it easily)


How would I do this on an AMD card?


catalyst control center, or ati tray tools
My reviews: http://boswerlk.wordpress.com
"stupidity is a cure for itself"

User Info: psiIocyborg

psiIocyborg
4 years ago#7
Must be your operating system. You want windows 7 64 bit, and maybe a bit more ram and overclock your CPU (get a decent fan for it). I have the same processor as you, but overclocked to 3.4ghz, 8gb ddr3 1600, and a gtx 570. Game runs at 30 fps with dsfix, 1920x1200. Motion blur / AA off.

User Info: daredevilwlj

daredevilwlj
4 years ago#8
Dex_Pyromaniac posted...
Configure both data.exe and darksouls.exe to the following in nvidia panel

Power management mode - prefer maximum performance
Texture filtering anisotropic sample etc. - on
Texture filtering quality - performance
Texture filtering trilinear optimization - on

I did this, turned off AA and motion blur in game, and have been flawlessly running it at 30 fps ever since (with a 660 gtx laptop card so yours should handle it easily)




i did this and my frame rate did increase somewhat. it still fluctuates like crazy, but it isn't always on 15 fps

User Info: daredevilwlj

daredevilwlj
4 years ago#9
I am definitely confident now that it is completely the software's fault that I only get 15 FPS on a regular basis. I purchased Batman Arkham City the other day and I am getting 50 FPS...no problem. There is no way in hell that Dark Souls in alot more advanced technically than Batman AC.

User Info: Edge_of_Ada

Edge_of_Ada
4 years ago#10
Weeeiiird. I have a gimped ATI Radeon HD 5450 and an AMD Athlon X3 processor, four gigs of ram, and no slowdowns except a teeny bit with bonfire resting and the white light leading to the Kiln.
That is not dead which can eternal lie
And with strange aeons even death may die
  1. Boards
  2. Dark Souls: Prepare to Die Edition
  3. Dark Souls PC Frame-rate problems.

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived