Can't become a vampire glitch, help!

#1BakaOrochiPosted 12/23/2012 11:51:41 AM
So I just got Dragonborn and Dawnguard DLC's, finished Dragonborn first (not sure if that counts for anything) then started Dawnguard. I got Serana, led her to the castle, and talked to Harkon. I also am a werewolf.

When I talk to Harkon, he DOES transform, but when he gives me the choice of becoming a vampire or be banished as a werewolf, if I choose vampire, he says "Be still" and sits there and doesn't do anything. Doesn't lunge at me like apparently he's supposed to or nothing. I can freely move around the room, interact with people, access the menu, but can't do anything else, can't even leave the castle.

He does banish me if I remain a werewolf and return to Dawnguard.

So is there a way to fix this? I tried messing with dialogue options, reloaded and retried at different save points but nothing.
---
http://www.bemanistyle.com
#2BakaOrochi(Topic Creator)Posted 12/24/2012 9:25:37 AM
Bah, turns out Dragonborn is probably programmed assuming Dawnguard was completed or installed. Worked fine when I took out Dragonborn,
---
http://www.bemanistyle.com