Try this re: fps issue

  • Topic Archived

User Info: GoIrish80

GoIrish80
4 years ago#1
Go to Documents > Criterion Games > NFS: MW > config. Open it with notepad and change the "Lockto30" setting to true. I know.....it doesn't sound right. Give it a try and let me know if it feels any different to you or not.
i5-3570k @ 4.2ghz | 8GB DDR3 | Nvidia 670 2GB SLI | 1TB HD x2

User Info: mrNickname

mrNickname
4 years ago#2
I have GTX670 and i gets the fps issue as well, PrecisionX shows there's downclock spikes on the GPU and VRAM every few seconds. Looks to me this is rather graphic driver issue and only way to fix is to have the graphic card locked on maximum performance with no adaptive power saving or other similar performance lock mechanism. I have not test this as well not really bothered to.
AMD i386 100MHz, 8MB RAM, Generic VGA graphic, play pong at 60fps

User Info: NeiL-KuN

NeiL-KuN
4 years ago#3
Thanks TC, worked for me.
Justice is a word used only by the weak

User Info: Sasuke_Itachi

Sasuke_Itachi
4 years ago#4
Doesn't this just lock you to 30 fps?
Black FC: 3740-1920-5856

User Info: mrNickname

mrNickname
4 years ago#5
Sasuke_Itachi posted...
Doesn't this just lock you to 30 fps?

It does exactly that. But i'm expecting a fix from either the driver or the game patch for this issue, because alot people are experiencing it.
AMD i386 100MHz, 8MB RAM, Generic VGA graphic, play pong at 60fps

User Info: alienkun

alienkun
4 years ago#6
Thanks man, your're a life saver :)
It still sucks that I can't run this game on 60fps :/ My rig runs BF3 on ultra settings with no problems :/

User Info: btaylorstl

btaylorstl
4 years ago#7
Ugh...if I wanted 30 fps, I'd play this on a console. Although maybe it would still be a lot better as long as it can stay completely steady at 30 the entire time, because consoles tend to have more dramatic spikes. I'll give it a try and see how it feels.
This signature will not change until the St. Louis Cardinals win the World Series. Started: 10/29/11

User Info: GoIrish80

GoIrish80
4 years ago#8
That's the only reason I'm doing it for now, I'm sick of it changing.
i5-3570k @ 4.2ghz | 8GB DDR3 | Nvidia 670 2GB SLI | 1TB HD x2

User Info: btaylorstl

btaylorstl
4 years ago#9
Yeah, so I set that option in the config and it does exactly what it says: locks the frame rate at 30 fps. Which is definitely massively preferable to the alternative. The game is perfectly playable at that rate (what I've seen of the console versions seems to be exactly the same except for occasional dips well below 30), so at least there's that. I still think I'm going to play Forza Horizon instead for a while because I'd hate to dump hours into this game only to have them fix it at some point when I'm about ready to move on. I'll wait for the hope of an optimal experience.

I loaded up Fraps to see what was going on, and it was kind of odd; it would sometimes be at 60 fps for a while, and then it would slash to 30 (kind of like a v-sync thing), but then it would often spike up periodically to higher frame rates, which is disconcerting to say the least. I have no trouble believing that my setup may not be capable of keeping it at 60 fps at all times, but it would be nice to be able to lock it at something like 45-50 instead of 30.
This signature will not change until the St. Louis Cardinals win the World Series. Started: 10/29/11

User Info: Double979

Double979
4 years ago#10
I've played the game 3 times since buying it. First time was running at 60fps, but my game didnt save. So second time playing I had to start over, again running at 60fps and this time I played a bit longer to make sure it saved. Third time playing it (from my save) it now runs at 20fps, except for in menus it goes back to 60fps

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived