PS3 Beta Codes Not working?

#1-Lionheart-Posted 6/14/2013 1:50:35 PM
Anyone else having this issue?

I received the e-mail this morning, and registered to my SE account just fine...but when I go to download on the PS3 it keeps saying my PS3 Beta Code is "No longer valid" but it hasn't been used :(

Has anyone in NA been able to dowload the client yet? Or do we have to wait for the PSN to update...
---
The Official THUN-darrggaah!!! of the Dissidia 012: Duodecim Boards
(I dreamt I was a moron...) Squall, regarding Laguna
#2winterzPosted 6/14/2013 1:52:39 PM
they sent out keys for wrong countries, if you are in canada you will need to set up a USA PSN account then u can redeem,

If you live in the US, you will need to set up an EU PSN account.

Thats what has been floating around today.
#3-Lionheart-(Topic Creator)Posted 6/14/2013 1:53:43 PM
winterz posted...
they sent out keys for wrong countries, if you are in canada you will need to set up a USA PSN account then u can redeem,

If you live in the US, you will need to set up an EU PSN account.

Thats what has been floating around today.


USA and Canada share the same PSN...

I also have an EU account and tried the code there and no luck :(
---
The Official THUN-darrggaah!!! of the Dissidia 012: Duodecim Boards
(I dreamt I was a moron...) Squall, regarding Laguna
#4winterzPosted 6/14/2013 1:55:07 PM
Very odd indeed, well the other option is if u have signed up with the first code on SOE's site, u could also use it to access the PC version if u have a decent system while all of this is getting worked out.
#5-Lionheart-(Topic Creator)Posted 6/14/2013 1:56:40 PM
winterz posted...
Very odd indeed, well the other option is if u have signed up with the first code on SOE's site, u could also use it to access the PC version if u have a decent system while all of this is getting worked out.


I don't own a PC which is the crappy part :(

The XIV Beta boards are full of people with the same issue, so hopefully it gets resolved soon...

I also opened a customer service issue with them, but SE NA have horrible customer service so I'm not holding my breath on that one...lol
---
The Official THUN-darrggaah!!! of the Dissidia 012: Duodecim Boards
(I dreamt I was a moron...) Squall, regarding Laguna
#6Catori20Posted 6/14/2013 2:01:39 PM
I am having the same problem! what a big screw up! sending out wrong codes..
#7-Lionheart-(Topic Creator)Posted 6/14/2013 2:12:51 PM
Ok so apparently USA and Canada DO have different accounts...

Canadian Users, you HAVE to follow this procedure to get it to work! We've been given US codes!

1. On your PS3, create a NEW USER with a US address!
2. AS THE US USER, sign up for the PSN (you MUST use a US address to sign up).
3. AS THE US USER, put in your PS3 promo code and download the beta client.
4. SWITCH BACK TO YOUR ORIGINAL CANADIAN USER ACCOUNT, launch the beta client.
5. CONNECT YOUR CANADIAN ACCOUNT TO YOUR SQUARE ENIX ACCOUNT when the beta client prompts you to input your SE account info
6. Let the client update and then start playing.

There is NO OTHER FIX for this at the moment.


Goddam it SE...they're so stupid..
---
The Official THUN-darrggaah!!! of the Dissidia 012: Duodecim Boards
(I dreamt I was a moron...) Squall, regarding Laguna
#8tyramailPosted 6/14/2013 7:04:27 PM
-Lionheart- posted...
Ok so apparently USA and Canada DO have different accounts...

Canadian Users, you HAVE to follow this procedure to get it to work! We've been given US codes!

1. On your PS3, create a NEW USER with a US address!
2. AS THE US USER, sign up for the PSN (you MUST use a US address to sign up).
3. AS THE US USER, put in your PS3 promo code and download the beta client.
4. SWITCH BACK TO YOUR ORIGINAL CANADIAN USER ACCOUNT, launch the beta client.
5. CONNECT YOUR CANADIAN ACCOUNT TO YOUR SQUARE ENIX ACCOUNT when the beta client prompts you to input your SE account info
6. Let the client update and then start playing.

There is NO OTHER FIX for this at the moment.


Goddam it SE...they're so stupid..



Genius Lionheart! Pin this to every board for SE's stupid mistake. Finally got it linked to my actual account using this method.