Unable to Download Patch Files

#1crmz0nPosted 8/27/2013 9:43:46 PM
Hi Guys, long time lurker here. This is my first post and I hate to waste it asking for help but I'm pretty desperate. I have successfully created an an account but when I try to update the game (2.5 gb). I keep getting the following error:

Unable to download patch files
[20512] [10009] [19900] [-2140076253]

I have attempted to update countless times in the last 3 hours. Any help is appreciated.
Thanks for reading.
#2AiChyanPosted 8/28/2013 3:16:02 AM
I encountered this problem too, and had no solution really.. just kept on trying and trying :( it worked on the third attempt. Its way too frustration and I almost gave up on playing because of it.
#3kyoselflovePosted 8/28/2013 3:17:17 AM
I had to keep trying, the 12th time it worked lol
#4xobx1Posted 8/28/2013 10:05:32 AM
I'm having the same problem and it's really frustrating. I tried at least 10 times last night, and it would usually download about 50 meg or so then quit. I've tried 3 times today so far, and still no luck. I know the servers are busy, and I could totally understand having trouble getting into a game, but I can't update this damn game? That's just nuts.

What's even stranger is that I don't really see this problem popping up anywhere either - I'm starting to feel like I'm one of the few people having this issue. :-)
#5yamisniperPosted 8/28/2013 10:16:20 AM
its something to do with your isp i think its like corrupting the download se could fix it
#6crmz0n(Topic Creator)Posted 8/28/2013 3:00:07 PM
Thanks guys for all your help.

@yamisniper: what do you mean se could fix it?