Stuttering

#1wolf_ravenPosted 6/6/2013 1:18:18 AM(edited)
Wondering if anyone else experiences this but every now and then I notice the game has a slight stutter when I'm walking around or exploring new areas ahead and my fps drop from 60 to 40 sometimes high 20's for 1 to 2 seconds. Is this due to the game loading more assets such as buildings, objects and etc ahead (steaming them in), for example trying to anticipate that I will be heading to point B while advancing from point A and begins loading those assets in?
I'm running the game on High except shadows, and supersample is off.
-My specs are-
Motherboard: GIGABYTE GA-M68MT-S2
Graphics: AMD Radeon HD6850 1GB
CPU: AMD FX-Series FX-8120 Zambezi 3.1GHz
Ram: 8GB (4GB x2) DDR3 1333
OS: Windows 7 Home Premium (64-Bit)
#2Dye_Ultralite45Posted 6/6/2013 1:53:57 AM
Definitely problem with a game it's unreal engine there is always these problems. Wait for a patch people with beastly computers are experiencing this as well, you aren't the only one.
---
i7 3770K 4.5 GHz, 24GB G.skill RAM 1600MHz, EVGA GTX 680 Superclocked SLI, 128GB Samsung 830 SSD, ASUS P8Z77-V, 1080p monitor, W7 64-bit
#3wolf_raven(Topic Creator)Posted 6/6/2013 2:20:59 AM
Dye_Ultralite45 posted...
Definitely problem with a game it's unreal engine there is always these problems. Wait for a patch people with beastly computers are experiencing this as well, you aren't the only one.


Ok thanks for clearing that up.
#4MashYouGoodPosted 6/6/2013 5:32:12 AM
Yeah. Same here.

Poor optimisation for a poor game.
#5iMpLuXPosted 6/6/2013 8:15:28 AM
Yea I have SS On and I get the occasional hiccup at the beginning of a new area or the start of a cutscene like when Nilin ran into the robot at the beginning of Ch 2.

Also they left the full CG scenes at the console 720p 30fps and they look terrible compared to the ingame scenes that they upscaled to 1080p 60fps. So yea poor pc port but hey at least we got it and when it's smooth, it beats the hell outta the consoles.
---
AMD FX 8350 BE, MSi 990FXA-GD80, 2x MSi HD 7950 TF3 3GB, 4x 4GB KHX DDR3 1600, PTeks TC14, Corsair TX850W - F3 240GB - K60/M65-FPS, Logi G710+/G600-MMO, Xig Ely
#6wolf_raven(Topic Creator)Posted 6/8/2013 2:16:12 AM
iMpLuX posted...
Yea I have SS On and I get the occasional hiccup at the beginning of a new area or the start of a cutscene like when Nilin ran into the robot at the beginning of Ch 2.

Also they left the full CG scenes at the console 720p 30fps and they look terrible compared to the ingame scenes that they upscaled to 1080p 60fps. So yea poor pc port but hey at least we got it and when it's smooth, it beats the hell outta the consoles.


Yeah I noticed the CG scenes look nasty, it looks compressed and distracts me from the otherwise beautiful in game visuals.
#7steker16Posted 6/8/2013 8:45:46 AM
i play the game fully maxed out, at 60fps, with no stutter. not sure what your guys issue is
#8Dye_Ultralite45Posted 6/12/2013 12:01:20 AM
I love how people post that and they don't even have their setup in their sig anybody can say that.
---
i7 3770K 4.5 GHz, 24GB G.skill RAM 1600MHz, EVGA GTX 680 Superclocked SLI, 128GB Samsung 830 SSD, ASUS P8Z77-V, 1080p monitor, W7 64-bit
#9jakeDiLLaPosted 6/12/2013 4:14:39 PM(edited)
it's cuz they're full of s***.

The game is stuttering for me as well, only when I go into a new area, otherwise its very smooth 60 fps.
---
i5 3570k / ASUS GTX 660 Direct CU II OC 2GB / 8GB ADATA XPG Gaming Series / 120GB ADATA S510 SSD
#10wolf_raven(Topic Creator)Posted 6/13/2013 3:06:44 AM
Dye_Ultralite45 posted...
I love how people post that and they don't even have their setup in their sig anybody can say that.


That's usually a good "troll" indication, always trying to stir up people in anyway they can.