Having trouble purchasing the collector's edition

#1kingxenomasterPosted 1/31/2014 10:36:23 PM
Hey there, i've been having problems purchasing products on square-enix's site.
The site won't accept my address, it offers a recommendation, I check the box
for the recommendation but it does not go past the address page.

I tried using both a US shipping address and a Canadian Shipping address but no dice.

Does anyone know what the issue is/or how to solve it?
#2EvesestzPosted 1/31/2014 10:39:34 PM
I'm having the same issue
---
PS/\/: YourIHero
Owning noobs day and night.
#3Deva_ZanPosted 1/31/2014 10:52:30 PM
[This message was deleted at the request of the original poster]
#4EvesestzPosted 2/1/2014 1:20:42 PM
Bump
---
PS/\/: YourIHero
Owning noobs day and night.
#5kingxenomaster(Topic Creator)Posted 2/1/2014 1:37:59 PM
Bump.
#6EvesestzPosted 2/1/2014 8:11:58 PM
Bump ;_;
---
PS/\/: YourIHero
Owning noobs day and night.
#7NoOnesTherePosted 2/1/2014 8:25:31 PM
I doubt this will help, as I was having a completely different problem, but nobody else is replying and it won't hurt to try it. I logged in at the main SE site, then took a link from there over to the store. When it asked if I wanted to use their recommended address I refused and stuck with the one I had entered.

Hopefully this solves your issue as well. If it doesn't go to the support page and submit a ticket. They're slow to reply though.
#8LeoChrisPosted 2/1/2014 8:27:02 PM
I'm having the same problem :/ I've purchased games for Square's online store a few years back without any problems though...
#9NoOnesTherePosted 2/1/2014 8:34:01 PM
LeoChris posted...
I'm having the same problem :/ I've purchased games for Square's online store a few years back without any problems though...


When you select your address choice and click "next" what happens? Does it just freeze/hang there or does it kick you back to the initial order page? It was doing the latter for me and that's why I had to log on before ordering instead of trying to do it during the ordering process.
#10EvesestzPosted 2/1/2014 8:44:11 PM
NoOnesThere posted...
I doubt this will help, as I was having a completely different problem, but nobody else is replying and it won't hurt to try it. I logged in at the main SE site, then took a link from there over to the store. When it asked if I wanted to use their recommended address I refused and stuck with the one I had entered.

Hopefully this solves your issue as well. If it doesn't go to the support page and submit a ticket. They're slow to reply though.


Holy $^*#. It worked!!

THANK YOU SO MUCH
---
PS/\/: YourIHero