Not getting any sound with optical audio

#1Jack_Ryder_2013Posted 1/1/2014 2:01:28 PM
It works fine with my ps3 and ps4 but xbox one will not detect my optical audio what am i doing wrong??
#2That_Damn_KidPosted 1/1/2014 2:10:13 PM
I think Dolby Digital is not working yet. MS said there's a patch coming eventually.
---
I'm not a kid, I just act like one
GT: ITS DAT DAM KID --- PSN: Lamburghini89
#3Jack_Ryder_2013(Topic Creator)Posted 1/1/2014 2:16:02 PM
Uncompressed stereo wont work either i cant get any audio at all
#4Jack_Ryder_2013(Topic Creator)Posted 1/1/2014 2:28:54 PM
Anyone else have this trouble?
#5Jack_Ryder_2013(Topic Creator)Posted 1/1/2014 2:41:43 PM
Well it works through my tv's sound but i want it to work through my surround receiver, blah...
#6Reflex-ArcPosted 1/1/2014 2:46:11 PM
Did you assign the digital input in your receiver settings to correspond with the video input you are using?
---
Case | Mother Board | CPU (OC'd!) | Video Card x 2 | RAM | PSU | SSD | HDD | Some Fans | Monitor | Mouse | Keyboard
#7Jack_Ryder_2013(Topic Creator)Posted 1/1/2014 3:01:10 PM
Its hooke up the same way my ps3 and 4 are and those work fine... Im just using the same optical audio cable i switch when i want to play a different system
#8Jack_Ryder_2013(Topic Creator)Posted 1/1/2014 3:23:19 PM
Im thinking this is just gonna work on its own at some point i read that other people have had issues with it also...
#9Rod1984Posted 1/1/2014 3:27:19 PM
you need to set it up, my games and movies are coming out as 5.1 dolby digital sound, the only thing they need to patch is for the tv app to out put in 5.1 since its only coming out as 2.1 even though I my sound receiver says its 5.1
---
PSN: mavrik1984 - GamerTag: rod1984 - Steam: rod1984
#10Jack_Ryder_2013(Topic Creator)Posted 1/1/2014 3:38:51 PM
Like i said its the same connection my ps3 and 4 use i should have no other set up than putting it on digital dts on the xbox itself i have set up a 360 before on this same receiver so i know how its supposed to go.. The xbox one seems to be having issues