Help! Can't select anything in transaction page.

#1DRmoellerPosted 2/16/2014 3:25:29 PM
I went to download the Titanfall beta and it wouldn't let me select anything after the Get it Free button. I couldn't select Confirm, Cancel, or Terms of Agreement. I've tried in other games, demos, and movies too and it's the same issue. What this means is I'm not able to download Anything on my Xbox. This is very annoying. Any ideas? I've tried turning off the Xbox.
#2DRmoeller(Topic Creator)Posted 2/16/2014 3:38:08 PM
Went to see if I can play a Twitch video and that won't work either if I try to watch from picking a game first. But I can watch any of the top videos once the app opens.
#3kidwgmPosted 2/16/2014 3:40:51 PM
https://mobile.twitter.com/respawn/status/435171235723374592?screen_name=respawn

That maybe the issue with Titanfall. Not sure you are having issues with the rest.
---
Currently Playing: Rune Factory 4
(Owner: gaming PC, 360, PS3, 3DS, Wii, WiiU, Xbox One)
#4DRmoeller(Topic Creator)Posted 2/16/2014 3:46:59 PM
Not the same issue but that's good to know, thanks. I did get my issue fixed though. I turned the system off, unplugged the power cable, and waited 5 minutes and it's working again. Weird. Glad I can pay Microsoft for stuff again. That was close.