Astro Mixamp Doesn't work with the Stereo Headset Adapter

#1nath999Posted 3/1/2014 7:51:07 PM(edited)
I was lucky enough to get into the beta program as well as get an early chat adapter from Microsoft and while the Dolby digital sound is great the mic does not work with the mixamp.

I have it similar to what we used to do with the 360 with the chat cable from the Mixamp going into the stereo chat adapter then to the controller but for what ever reason the mic doesn't work.

If I unplug the headset from the mixamp and plug it directly into the stereo headset adapter viola everything works except you lose Dolby digital support since it's a Stereo Headset adapter.

Come on Microsoft it shouldn't be this freaking hard!

Before anyone asks yes I have the latest Beta update and have updated my controller.

I reported this on the private Preview Forum but who knows if that's going to get anywhere.
---
PSN / GT: Deathstroke XII
SSBB:2578-2790-7862
#2I_VTEC_Power_IPosted 3/1/2014 9:00:16 PM
Well that's upsetting.
---
Xbox Live : I VTEC Power I PSN : I_VTEC_Power_I
Bring back Honda F1
#3Lawboy2Posted 3/1/2014 9:10:39 PM
http://www.ign.com/articles/2014/03/01/xbox-ones-march-patch-to-include-better-audio
#4rubberGasketPosted 3/1/2014 11:48:39 PM
Did you update the controller with the adapter and mix amp plugged in?
---
If I don't reply to your post it's because I have you on my ignore list.
#5120N7Posted 3/2/2014 12:04:17 AM
Doesn't sound good. Have you got the adapter set to chat only?
#6nath999(Topic Creator)Posted 3/2/2014 12:05:27 AM
rubberGasket posted...
Did you update the controller with the adapter and mix amp plugged in?


Indeed I did. Followed the instructions that came with the headset adapter too by taking the batteries out first.
---
PSN / GT: Deathstroke XII
SSBB:2578-2790-7862
#7nath999(Topic Creator)Posted 3/2/2014 12:07:07 AM
120N7 posted...
Doesn't sound good. Have you got the adapter set to chat only?


Where is that option?
---
PSN / GT: Deathstroke XII
SSBB:2578-2790-7862
#8SVT52986Posted 3/2/2014 5:15:57 AM
And that would be my biggest fear. I have both the Astro A40s and a pair of A50s that I just got in December. I got my MS adapter last Thursday from the Microsoft Store and tried it out even though I am not in the beta. What I noticed is that whenever I talked into the mic, the indicator came on everytime in both Battlefield and Plants vs Zombies. I couldnt hear anybody but I figured the adapter was functioning somewhat. If the update coming out this month does not fix that then I am back with headsets that sound great but you cannot use for chat. I am beginning to wonder if I should just buy one of the One specific headsets releasing on the 7th. Or is it possible the beta preview is not working for everything since MS really has the adapter dated to release on the 7th as well but thecMS store shipped early?
#9120N7Posted 3/2/2014 6:33:22 AM
nath999 posted...
120N7 posted...
Doesn't sound good. Have you got the adapter set to chat only?


Where is that option?


Not sure. Seem to remember reading it. Probably mistaken.

There was a problem with controller update in initial preview. Use Xbox Preview forums.
#10120N7Posted 3/2/2014 6:35:39 AM
nath999 posted...
rubberGasket posted...
Did you update the controller with the adapter and mix amp plugged in?


Indeed I did. Followed the instructions that came with the headset adapter too by taking the batteries out first.


There is a thread about this on the Beta forum.