Anyone else have save issues at the end of Guacamelee?

  • Topic Archived
  1. Boards
  2. Xbox One
  3. Anyone else have save issues at the end of Guacamelee?

User Info: Swan3624

Swan3624
2 years ago#1
I am pretty pissed right now. I was playing the last level of Guacamelee game with a friend of mine and everything was going well. We made a ton of progress, uncovered almost all of the final map, and then beat the final boss.

But I didn't get any achievements for that boss defeat. Maybe it was just a co-op thing... maybe I was supposed to beat the boss alone. No big deal. Then it asks if I want to put my score on the leaderboard. But it doesn't let me... it keeps telling me to reconnect to the Internet. I tried dozens of times but it keeps immediately bringing back a connection error.

Whatever. A little annoying, but whatever.

But then I realize when I'm at the main menu that my name is not in the upper-left. So I sign in to my account, something that I shouldn't have to do since I was playing on my account the whole time, and then the horror of lost progress is realized... the game didn't save ANYTHING my friend and I did. That was 2 hours of progress, roughly 20% of my overall game time.

I tried to sync my save data, deleted the console data and redownloaded it, signed out and back in... and nothing. My save data isn't completely wiped, but it didn't save a damn thing from that two hour session.

What happened? Has anyone else had this happen to them?
  1. Boards
  2. Xbox One
  3. Anyone else have save issues at the end of Guacamelee?

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived