Xbox One privacy settings/content restrictions issues.

  • Topic Archived
  1. Boards
  2. Xbox One
  3. Xbox One privacy settings/content restrictions issues.
1 year ago#1
This is something that's been driving me crazy because it seems like I am the only one with this problem, and there's not a lot of it floating around the internet. When I try to purchase something in the Xbox Store, I get a message saying something like:

Change your settings:
You have settings in place that disable you from buying content that is not free. Go to your settings menu and enable "purchase content", if this is a child account a parent will have to do it.

Well, I go the settings menu and select "Privacy and content restrictions" and what I see is another dumb message under both the privacy column and content restrictions column that says:

Your privacy settings/content restrictions are in effect, but can't be changed until we connect to the service.

Then it never connects. I have no idea how to make it connect. Yes, I am connect to the internet. Yes, I am signed into Xbox Live. No, it is not a child account (or so it should not be, I recently found out about the "Promote" thing for accounts who's owners are past 18 and did all that stuff myself). My NAT rating is open and everything is good. When I loaded the "parent" account onto the Xbox One (the account mine was connected to) I found that one had access to the privacy and content restriction settings. As it appears to me, it looks like a bug in the system as my access seems to be blocked for no apparent reason, unless this is a severely delayed effect that it still hasn't registered that I have "promoted" my account from my 360, but that was two weeks. I can still change these settings on the Xbox website but it seems to have no effect on the Xbox One. So does anybody have a fix for me? This has been going on for a month it almost makes me regret I spent $400 on this thing in the first place.

Note: sorry if this seems like a LOT of information, I'm just trying to cover all the corners of my issue since it seems a little more of a unique case, and otherwise people give me "solutions" that I've already tried.
1 year ago#2
Man I really don't know what to say is have you tried a Hard Re-Set yet? Another thing you might try is deleting your GT and re down loading it.. Other than that I dunno and hope you get it worked out..
---
>The World Is Yours< *Al Pacino*
1 year ago#3
I just tried deleting my account from the system and brought it back but that just didn't work. I'm not completely sure what you mean by "hard reset" but I have tried deleting the console to factory defaults, but that didn't work either.
1 year ago#4
*resetting* the console to factory defaults.
1 year ago#5
It definitely seems like an isolated issue and likely will require you to contact Microsoft support for assistance.
---
If you tell the truth, you don't have to remember anything - Mark Twain
  1. Boards
  2. Xbox One
  3. Xbox One privacy settings/content restrictions issues.

Report Message

Terms of Use Violations:

Etiquette Issues:

Notes (optional; required for "Other"):
Add user to Ignore List after reporting

Topic Sticky

You are not allowed to request a sticky.

  • Topic Archived