Card Count Resets to Zero (bug?) (potential spoilers)

#1jasexavierPosted 3/14/2013 2:37:13 PM
I finally completed everything in this game, at least I've gathered 49 cards and all the ??? items through the White Cube, and found it to be one of the most frustrating games I ever enjoyed playing. After getting the 49th card I saved at a checkpoint and quit the game. When I returned to the game the save file said "50 cards" which I knew was a possible glitch but when I loaded the game it said "0 cards" and all my card pages were empty. All the ??? items were still there.

I thought briefly about editing the save file to restore them but discovered that if I went as though to open the already open chests that had contained the cards that they were restored to my inventory. I used the FAQ here to go back and quickly re-collect all 49 cards. I then saved at a checkpoint and exited the game. Curiosity struck about an hour later and I opened up the game. The save file said "49 cards" this time but when I loaded the game it had once again reset to zero. It did not happen either time when I had a save game with 48 cards.

I've search the forum here as well as Google and haven't found anyone else having this same problem. If it makes a difference I'm running Linux (Ubuntu 10.04) and Air 2.6.

Is this a bug or is it just part of the intentional frustration of the game?

Also, this is my first post here so hello! Thank you in advance for any help.

Jason
#2LiquidDumpPosted 3/14/2013 10:26:36 PM
[This message was deleted at the request of the original poster]
#3LiquidDumpPosted 3/14/2013 10:29:34 PM
Ignore that previous comment, it was meant for a different question. If you need a .sol file to get you back, I can help you with that.
---
I am a Monster Hunter
#4LiquidDumpPosted 3/14/2013 10:31:52 PM
Also, I've come upon a glitch where you get 50 cards, but you don't really have 50. Maybe the glitch is related to yours?
---
I am a Monster Hunter
#5jasexavier(Topic Creator)Posted 3/14/2013 10:41:28 PM
I got the 50 card bug once as well. The load game screen still shows me as having 49 cards this time, and showed me as having 50 before, but if I load the game they're all gone. All the boxes and gates are still open, my inventory just says 0 cards and shows no cards in any of the slots.

I don't need a save game file; I kinda just want to know what's going on. I suppose it would be a test to see if a different save game file has the same problem on my computer.
#6clayflute22422Posted 3/16/2013 11:17:20 PM
sean here. this is weird o_o ,,, and honestly i have no idea what is causing it. i just checked the source code to double check, but the only time cards ever get "turned off" is in the delete save routine, and the delete sav eonly gets called if you delete it through the title...hmm..


so the number of cards (displayed on title) is stored independently of the array of card states. it being zero on startup means it somehow got set to zero....but that would only be through deleting in the title, which didn't happen.

then, you got all the cards again, but somehow the array got set to all "false", too.

in short, I have no clue o_o...unless i missed something, which is likely the case. I don't want to blame your OS since it's almost always the programmer's (mine) fault, but maybe there was some weird storage limit set for the save and parts of the save got nuked, or some save failed...dunno.
---
||||||||| |||||||||||
#7jasexavier(Topic Creator)Posted 3/18/2013 2:05:19 PM
So I made a backup of that save and started a new game. I played through to the end, got the 48 main cards, got all the ??? items, then saved and quit. I started the game and the menu said 48 cards and I had 48 cards revealed in my inventory once the game was loaded. I then retrieved the red card, which increased my count to 49. I wiggled back down to the main walkway there, saved at the checkpoint, and quit the game. I then started the game back up again and the menu lists my saved game as having 50 cards. I loaded that game and my card inventory is once again blank. The count is zero cards and no cards are shown in the inventory. I cannot open the 49 gate (I had opened it in my previous game before quitting and losing the cards).

Would it help if I uploaded a copy of the save game file? I did not save after loading it so it still shows 50 cards in the menu and only resets to zero once I load the save. I also have a copy of the save that shows 49 cards in the menu but zero once the game is loaded.

Also, not sure if this is a bug or not, but if I select "Return to Nexus" while in the Debug World I get teleported to somewhere in the glitched out area and have never found my way back without just quitting and reloading the game.
#8PotentChiliPosted 3/21/2013 12:02:19 AM
This just happened to me right after getting the 49th card through the pit glitch trick :\ This really sucks because I've been working on the Anodyne Wikia pages for all the end-game content, and now I can't get past Gate 49 because it keeps saying I either have 0 or 2 cards :(
#9PotentChiliPosted 3/21/2013 12:05:27 AM
I'll probably end up playing through again, but I'll make a save file before getting Card 49. Note I'm also running Ubuntu (12.10) and Air 2.6.
#10PotentChiliPosted 3/21/2013 1:30:33 AM
Sorry to post again, but another user has confirmed this in the comments of the Card 49 page on Wikia http://anodyne.wikia.com/wiki/Card_49