Graphics issue; red grass patches, purple water and cyan player colour is yellow

#1PsychochriaPosted 5/14/2009 9:47:16 AM
I have been a long time Age of Empires II player, and have once suffered from the classic red grass and purple water graphics issue that a lot of people suffer from. However, using one of the below solutions, it eventually corrected itself. Recently, I installed Windows 7, build 7100 as my main operating system. AoEII (Conquerors exp. too) did not work on the original Windows 7 build, but now does, however, no matter what I do, scouring the internet for solutions and ways to solve the problem the graphics issue of the red grass and purple water stay. Here are the solutions I've read about and tried, all to no avail.


Changing the resolution
Alt tabbing
Opening a folder before the game loads
Unchecking "CPU 1" on the "Set Affinity" box in Task Manager
Updating graphics drivers to most recent
Updating DirectX to most recent
Running the game in compatibility mode for XP, Vista, 98, etc.

None of these solutions work at all, the green grass is still red, and the water is still purple.

Here are my system specs.

Windows 7 Ultimate 64-Bit Build 7100
AMD Athlon 64 6000+ ~3.0GHz
2GB RAM
NVIDIA GeForce 8800 GT
Direct X 11
Running at 1920x1080

Can anyone recommend any other solution to the graphics problem? Thanks.

Here's a picture of the issue (screenshotting doesn't show the graphics problem)

http://img4.imageshack.us/img4/6167/140520091107.jpg
---
./|,-``\(o)_\,----,,,_ Power, Wisdom, Courage.
( `\(o),,_/` : o : : :o `-,
#2BurningSwor145Posted 5/14/2009 3:51:56 PM
Run it at a lower resolution.
---
I just can't stand the face of that...Bobo Doll... - Allan Shore
#3Psychochria(Topic Creator)Posted 5/14/2009 6:30:48 PM
Changing the resolution

First thing I said I did, bud.
---
./|,-``\(o)_\,----,,,_ Power, Wisdom, Courage.
( `\(o),,_/` : o : : :o `-,
#4KotG LuvinPosted 5/14/2009 8:17:10 PM
My god, that algae bloom will kill all the fish.
#5zyxomma100Posted 5/14/2009 9:38:53 PM
I honestly have no idea what to tell you. That problem fixes itself every time I alt-tab. I assume you know the risks of running a beta OS, but... I can't see why it would do that.
#6SeraphLancePosted 5/15/2009 2:53:23 AM
On Vista (and 2003), every time I see that, it's fixed either with alt-tab or installing the latest version of dx9.

If none of those work on Windows 7 it's a dark day indeed.
---
"If attacked . . . ., always find or manufacture enough threat against them to cause them to sue for peace."
- L. Ron Hubbard
#71hijklm1Posted 5/22/2009 10:41:20 AM
try this... wen u see red grass n purple water... this is wat i do.. :) press da "window key" das wat i do.... wat uv to do is jus widout closing ur game get to ur desktop :) do dat.... n then switch age of empires again.... see if da color gone right... if not do it again... BUT this time... open some folder... say MY COMPUTER .... n then... its MAGIC :P
#8Psychochria(Topic Creator)Posted 5/23/2009 7:10:14 AM
Are you kidding me? Did you even read the first post at all?
---
./|,-``\(o)_\,----,,,_ Power, Wisdom, Courage.
( `\(o),,_/` : o : : :o `-,
#9GroundJordanPosted 5/24/2009 9:46:05 AM
ok everyone
Here are some steps on how to fix the colors issue for users on Vista playing the game.

Open your windows explorer and go to c:/program files/microsoft games/age of empires II/age2_x1 folder

Right click on the age2_x1.exe icon and select properties - go to the compatibility tab

add the three check marks you see below in the last three boxes of the settings section

click apply and ok and your all set - issue resolved... well for some of you that is

This don't actually resolve the issue - it just helps allot lol



if that don't work for you try putting a checkmark in the run in windows xp compatibility mode
Have fun and enjoy your games
#10reiko sawamuraPosted 5/30/2009 11:11:43 AM
I'm having this problem as well, and have yet to find a way to fix it...
---
"You could lock Luffy in a box with a paper clip and a half eaten cup of yogurt and he'd amuse himself. " --Some guy.