Can't seem to get the console commands to work...

#1RazumPosted 12/7/2012 2:15:15 PM
Alright. Click on shortcut, add -console at the end of the Target Box OUTSIDE of the " " with a space. Still can't get the console command box to pop up.

"C:\Program Files (x86)\Activision\Vampires - The Masquerade Bloodlines\launcher.exe" -console

Anyone have any input on this? Running Windows 7 if that matters.
---
UMvC 3 Team:
Hagger/P.Wright/Spencer
#2RevanXXXIIIPosted 12/7/2012 3:28:42 PM
You need to press ~ to access the console. It's the key under Esc.
#3vlado_ePosted 12/7/2012 4:55:57 PM
"launcer.exe" what version is that? The CD version I have has "vampire.exe" there. Is it the D2D one (I think they got renamed to GameFly?)?

Anyway, normally what you've done should have worked, it may be the version that's not actually supporting it. Is there a vampire.exe? Try launching it instead, see what happens.

Otherwise, you can try a small hack - I don't guarantee it's going to work but I suspect it would:

1. Go to [install directory]\Vampire\cfg\
2. Find autoexec.cfg. If you don't have it, then just create a blank file with that name (make sure it actually has that extension). Also, you should really consider installing the Unofficial Patch.
3. Open the file with Notepad.
4. Type in console 1
5. Save it.

That should, in theory, enable the console. I haven't tested it (had no real reason to) and can't at the moment but I see no reason why it shouldn't work.
---
We do what we must / because we can. / For the good of all of us. / Except the ones who are dead.
#4vlado_ePosted 12/9/2012 7:45:48 AM
vlado_e posted...
Otherwise, you can try a small hack - I don't guarantee it's going to work but I suspect it would:

1. Go to [install directory]\Vampire\cfg\
2. Find autoexec.cfg. If you don't have it, then just create a blank file with that name (make sure it actually has that extension). Also, you should really consider installing the Unofficial Patch.
3. Open the file with Notepad.
4. Type in console 1
5. Save it.

That should, in theory, enable the console. I haven't tested it (had no real reason to) and can't at the moment but I see no reason why it shouldn't work.


OK... I just tried it and it doesn't work. I also tried con_enable and enableconsole to no effect again. I'm stumped. I mean, I rely on knowledge mainly from Half-Life to do console-y stuff in Bloodlines, since Source is pretty compatible with the old things I know (and I never got far into tinkering with Source games). I can't seem to find what the variable or command to enable the console is. And cmdlist/cvarlist don't actually help, since they dump all the info in the console itself and I can't find a way to save that to a file (so I can view it and search it more easily.

So, with that said, the only other thing I can think of, is even more of a hack than the above. Put all the commands you want in autoexec.cfg - what that does, is it just executes them - it's the same as launching the game and typing everything in the console itself. Well, with the difference that 1. its faster and you don't have to type it yourself every time 2. works even with the console disabled. If you want to use something but not all the time, bind it to a key, so you can press a button and it works, for example, to bind noclip to any key, add the following line
bind p "noclip"
which means that you cna now press p to use it. Substitute that with any key you want.
---
We do what we must / because we can. / For the good of all of us. / Except the ones who are dead.
#5JobeStroudPosted 12/9/2012 8:16:15 PM
You don't need to play the game from launcher.exe. just go to the install directory and just put a shortcut to vampire.exe to desktop. You can put the -console in there and the game will work just fine
#6Razum(Topic Creator)Posted 12/9/2012 8:21:37 PM
Thanks for the help guys, got it working with the suggestions given.
---
UMvC 3 Team:
Hagger/P.Wright/Spencer