This is a split board - You can return to the Split List for other boards.

How can I force a local static IP? Setting up MySQL Server for XBMC

#11tspirtle2(Topic Creator)Posted 5/29/2012 8:14:59 PM
From: Entegy | #009
I would just go in your router and assign a DHCP reservation.

I tried that, but I don't think the MiFi allows that. This is the closest option it has, but this only gives you a list of assigned DHCP's. It doesn't allow you to reserve any:

http://i.imgur.com/ShvFU.png
#12tspirtle2(Topic Creator)Posted 5/29/2012 8:23:22 PM
Ah, wait... Is this what I need? I don't know what to do with it, even if it is :/

http://i.imgur.com/Ijngg.png
#13LordSeiferPosted 5/29/2012 8:25:09 PM
no.

thats for opening ports when you already have a static ip setup
---
^ this
#14HeyDudePosted 5/29/2012 8:31:22 PM
The proper way to do this is to create a DHCP Reservation on the router. You enter the MAC address of the client and the IP that you want it to get every time.

If your router can't do that, then you can manually configure your computer to a static IP, but your router won't know you've done that and might have already assigned it out (in which case, do like the other poster said and use a static IP configured on the computer that is not in the DHCP pool).
#15tspirtle2(Topic Creator)Posted 5/29/2012 8:36:40 PM
From: HeyDude | #014If your router can't do that, then you can manually configure your computer to a static IP, but your router won't know you've done that and might have already assigned it out (in which case, do like the other poster said and use a static IP configured on the computer that is not in the DHCP pool).
I think this is going to be my best bet, since the MiFi doesn't seem to have the options that I need to make DHCP reservations.

As I said before, its DHCP IP pool is .100 through .254.... What IP could I assign outside of that pool? I was going to go with .255, but Lonestar mentioned that one is for broadcast. Is virtually any other number open?
#16Lonestar2000Posted 5/29/2012 8:54:16 PM
tspirtle2 posted...
From: HeyDude | #014If your router can't do that, then you can manually configure your computer to a static IP, but your router won't know you've done that and might have already assigned it out (in which case, do like the other poster said and use a static IP configured on the computer that is not in the DHCP pool).
I think this is going to be my best bet, since the MiFi doesn't seem to have the options that I need to make DHCP reservations.

As I said before, its DHCP IP pool is .100 through .254.... What IP could I assign outside of that pool? I was going to go with .255, but Lonestar mentioned that one is for broadcast. Is virtually any other number open?

You can use any IP address from .1 to .99.
---
Rumble Roses. Someone enters the room.
Them: O_O Me: What?! I always play games without my pants on!- Inmate 922335
#17Davel23Posted 5/30/2012 4:35:43 AM
Lonestar2000 posted...
tspirtle2 posted...
From: HeyDude | #014If your router can't do that, then you can manually configure your computer to a static IP, but your router won't know you've done that and might have already assigned it out (in which case, do like the other poster said and use a static IP configured on the computer that is not in the DHCP pool).
I think this is going to be my best bet, since the MiFi doesn't seem to have the options that I need to make DHCP reservations.

As I said before, its DHCP IP pool is .100 through .254.... What IP could I assign outside of that pool? I was going to go with .255, but Lonestar mentioned that one is for broadcast. Is virtually any other number open?

You can use any IP address from .1 to .99.


He can't use .1, that's the router's address.
---
Your mom's box.
#18tspirtle2(Topic Creator)Posted 5/30/2012 5:00:05 PM(edited)
Whenever I try to assign an IP, I lose access to the internet. If I try to let Windows automatically fix the problem, it just says "DHCP isn't enabled" and changes my settings back to automatically assigning an IP.

Here's what I have entered:

http://i.imgur.com/c8fo0.png

Is there something I'm doing wrong? I think my problem lies within the MiFi device
#19Davel23Posted 5/30/2012 7:13:49 PM
Put 192.168.0.1 as the DNS server.
---
Your mom's box.