This is a split board - You can return to the Split List for other boards.

Can anyone help me with a problem I'm having with my DDR pad?

#1DragonPuppy7Posted 5/30/2012 7:52:32 PM
I have a metal DDR pad for my computer that I've had for many years. I used to play Stepmania all the time on my computer years ago, but until recently I haven't been able to get it working on my computer. This is because my old adapter for the DDR pad used to plug into the parallel port on my computer and I haven't been able to find a working driver (The one I used to use was deleted from the website I originally got it from and I was never able to find it again). So, recently I purchased a new adapter that plugs into a USB port and came with a driver. I installed Stepmania along with some songs and tried out the DDR pad. The pad worked, however, I encountered a serious problem that I have been unable to fix. For some reason I can't press the left and right, or the up and down buttons simultaneously, if I do the game acts like I pressed neither button; however, it works fine to press any other two buttons together such as left and down or right and up.

This problem is completely ruining the game for me. One of the most serious problems it causes is making it completely impossible to hit any of the doubles with left and right or up and down. It can also cause problems when I need to hold a button. For example, if I need to hold down the left button I can hit any up or down arrows that appear while I'm holding it, but I can't hit any of the right arrows. Additionally, generally when I play my feet are on the left and right buttons when there aren't any arrows to hit. This makes it so that if an arrow on the right comes up I can't just push the right button, instead I have to first move my left foot somewhere besides the left button before I can hit the right button. Does anyone know what I might be able to do to fix it? It's great to be able to play DDR again, but it really sucks that I keep failing songs because of this problem.
Everyone screen looks some times
#2PolarisPosted 5/30/2012 8:13:16 PM
It's a USB problem, and one reason why some people still recommend plugging keyboards into the PS/2 port instead of the USB port.

The USB protocol encodes data into packets and when too many keys or certain key combinations are transmitted simultaneously it corrupts the information in the packets so nothing registers. Plugging the same keyboard into a PS/2 (assuming the keyboard supports n-key rollover) all the keys would have been registered correctly, but not over USB. I'm assuming the same issue applies to your pad. Unfortunately PS/2 ports are specifically designed for mouse and keyboard only, and I doubt there is any way to get your dance pad to work over PS/2.

The only potential workaround I could see is if there is some way you could define macros for up+down and left+right that did not require you to actually step on those positions simultaneously. I have no idea if this type of feature would be supported but it's the best I could think of, sorry.
#3DragonPuppy7(Topic Creator)Posted 5/30/2012 9:46:13 PM
After some research it doesn't sound like it's a USB problem, but a problem with the adapter itself. From the sound of it, the problem occurs because the adapter is mapping the arrows to axes instead of buttons. Because left/right and up/down are on the same axes it can't detect when both left/right or up/down are pressed. It's apparently a very common problem with the adapter I got (the Dilong pu203) but many other USB adapters don't have this problem because they correctly map them as individual buttons instead of to axes. Apparently this problem can be fixed by holding start, select, and up simultaneously for 3 seconds. Doing that is supposed to make the adapter enter dance pad mode which fixes the axes problem; however, it didn't work for me and it sounds like it hasn't worked for many other people.

I was able to find multiple topics on the stepmania forums addressing this problem. People posted many solutions that worked for them, but none I have tried have yet to work for me. This is due in part to the fact that many of the posts people made were posted years ago and many of their links to drivers or other files no longer work. I really hope I'll be able to get this working, the game is playable but it's just not fun to lose because I keep missing things that are literally impossible to hit because of this problem. If nothing else I guess I could buy another adapter (this one only cost me around $5) that I know won't have this problem, but if possible I would really like to be able to get this one working, if for no other reason than I would probably have to buy the adapter on ebay or amazon and it would take a few days to ship.
Everyone screen looks some times
#4thaandieselPosted 5/31/2012 12:06:31 AM
i beleive i can help you, but i have to get home first. sorry, but i do know, that i had lag when using a parralel port for the connection!
<- Q9550@3.3 - G31M - Hyper 212+ - 4 gig 1066 - GTX 470 650mhz - xfi 5.1 usb - turtle beach HPA2 true 5.1 - 64 gig Mushkin SSD ->