This is a split board - You can return to the Split List for other boards.

Need urgent PC help! Thanks!

#1Shadowblade320Posted 6/6/2012 4:09:12 PM
I just recently got a "Free" dell windows XP desktop PC. That I plan on upgrading in the future. BUT right now I'm just using it for basic web browsing. However that's the problem. I can't surf the web at ALL using I.E. Because when I type in a website and press enter all it shows is a blank plage. And I mean a pure white blank page. NO lettering on it at ALL. Also I've tried getting to the internet options, but it won't even let me do that. It like displays for a half second and disapears very quickly. I can't even see it. And I have no other browsers to use. I don't think it's the internet. Because I'm typing this from another PC in the house. And when I go look at the "internet" thing in the bottom right corner. It says currently connected and speed is 100.00mbs. What do I have to do to solve this issue? I was actually thinking it could be some internet drivers I'm missing or something. What could I do to fix it? Thanks!
---
http://i.imgur.com/qMzKo.gif
#2redrum187Posted 6/6/2012 4:18:40 PM
if you have a winxp based dell it's probably not worth upgrading since it's likely very outdated. however for your internet problems have you downloaded the latest ethernet drivers from support.dell.com or you could download drivers from intel since most intel based dell pc's use intel nic.
---
i still haven't found what i'm looking for...
#3Shadowblade320(Topic Creator)Posted 6/6/2012 4:22:43 PM
How will I be able to do it if I can't access any websites due to blank pages?
---
http://i.imgur.com/qMzKo.gif
#4dragon12844Posted 6/6/2012 5:13:39 PM
Download the driver updates to a flash drive
---
brawl:4052-1527-6415/Mh3 Phyd89/mkwii:2277-7046-8686/
GT: Fire Hazerdz