This is a split board - You can return to the Split List for other boards.

Any idea why my chassis LEDs stopped working?

#1giglamesh99Posted 6/18/2012 10:42:17 AM
I put my new system together last week and everything was functioning perfectly. I shut my computer down for the weekend and booted up today to find that my LEDs arent working.

I opened my pc up and checked all the connections. Everything is connected securely and properly.

The only thing I noticed was that I think there was a power surge/short in my house on saturday because I came home and a couple of digital clocks and the cable box was reset. But my system was off at the time so I dont know how that could've been effected.

Also, the circuit board my LED's are connected to is also the same board my chassis fans are connected to and all my fans have power, just no LEDs.

Any idea what it could be or how to fix it? I dont think there's anything in my bios to control that. Using a p8p67 deluxe asus motherboard.
#2giglamesh99(Topic Creator)Posted 6/18/2012 11:18:16 AM
Bump
#3giglamesh99(Topic Creator)Posted 6/18/2012 12:19:15 PM
Anyone?
#4R4MBO2KII8Posted 6/18/2012 12:57:34 PM
Maybe they are just faulty
---
i5-2320 @3.0 Ghz/s //Kingston HyperX 8gb DDR3 // ATI Radeon HD6670 2GB GDDR3 //Corsair GS700 // 1.5Tb HDD // Foxconn H61MXL // Acer S230HLBD 23" //
#5giglamesh99(Topic Creator)Posted 6/18/2012 1:30:56 PM
I don't know. They were working fine after I closed the system up and when I shut down for the weekend.

I guess I'll just disconnect all leds, reconnect them and see what happens.

Worse comes do worse I'll use a meter and make sure voltage is coming from the connector from my psu and check if the board has power.

My usb leds are connected to the circuit board and my power on led is connect to my mobo... the mobo one should work atleast.
#6giglamesh99(Topic Creator)Posted 6/18/2012 4:02:54 PM
Any other suggestions or anything else the problem could be?
#7RawePosted 6/19/2012 12:11:30 AM
What case do you have? On my cm 690 II advanced mid tower there is a button on the to near the power and usb ports that turns my led lights on and off.
---
PS3 - Wii - 360 - PSP - PC Gamer
Intel i5-2500k - Asus P8P67 Pro B3 Rev - EVGA GTX 570 - 8GB G.SKILL RipJaws X DDR3 1600MHZ