This is a split board - You can return to the Split List for other boards.

Getting some ridiculous load times from GTA IV. Any help?

#21JKatarnPosted 7/18/2012 2:08:04 PM
I find it odd that Vsync would have any bearing whatsoever on loading times, it's usually a strictly runtime setting that synchronizes your framerate to the vertical blank rate of your monitor.
---
Asus P8Z68-V LE | Core i7 2600K | 8GB G.Skill Ripjaws DDR3 | EVGA GeForce GTX 460 Superclocked
PS3 | PS2 | PSP| Wii | 3DS | DS | X-Box 360 | X-Box | NES
#22KalirionPosted 7/18/2012 2:10:44 PM
JKatarn posted...
I find it odd that Vsync would have any bearing whatsoever on loading times, it's usually a strictly runtime setting that synchronizes your framerate to the vertical blank rate of your monitor.


It is odd, and an indication of very bad coding.
---
Don't be scared of nightmares; make them be scared of you.
#23JKatarnPosted 7/18/2012 3:27:40 PM
Kalirion posted...
JKatarn posted...
I find it odd that Vsync would have any bearing whatsoever on loading times, it's usually a strictly runtime setting that synchronizes your framerate to the vertical blank rate of your monitor.


It is odd, and an indication of very bad coding.


I can hear the meeting now..."So, I've determined that we can increase performance by 3% if we integrate the disk caching/loading routines into the Vsync routine..." "Umm...our testing indicates the loading times have increased by 300%" "Yeah, but.....3% more performance!"
---
Asus P8Z68-V LE | Core i7 2600K | 8GB G.Skill Ripjaws DDR3 | EVGA GeForce GTX 460 Superclocked
PS3 | PS2 | PSP| Wii | 3DS | DS | X-Box 360 | X-Box | NES
#24datopgamerPosted 7/20/2012 12:12:56 AM
Just checked around after I got tired of the crappy load times and found out that if you press the 'home' key and open your gfwl while it's loading your load times will drastically drop. I only checked on this because the vsync thing did nothing for me. Now it goes to 2 characters and the game loads after about 5 seconds.
---
I5 3570k @ 4.2ghz, 12 gigs DDR3 memory, Asrock Z77 Extreme 4, 2x EVGA GTX 670 4gb SC sli, Corsair 750TX PSU, ASUS 24" monitor, 2x 23" Acer Monitors
#25Cyborg1000Posted 7/20/2012 12:30:56 AM
Just an idea here, but try clearing the game cache through Steam. I had this problem yesturday when I got Just Cause 2, after I cleared the cache, the game loaded and runs fine now.
---
www.facebook.com/mardy423
Xbox Live GT- ChrisHaloBoss
#26Artemis_Fei(Topic Creator)Posted 7/20/2012 2:13:43 AM
So, found a second fix.

I just enabled Vsync in game. It worked perfectly. Capped my frames too.

This game is confusing.
---
CEnco De Mayo. [Proud Participant]
Epic. [1:23]
#27BurningSwor145Posted 7/20/2012 3:15:57 AM
Weird, this game never gave me performance woes. It loves quad and tri-cores though.
---
"Mostly Harmless????"
#28romsnbombsPosted 7/21/2012 5:12:57 AM
Artemis_Fei posted...
So, found a second fix.

I just enabled Vsync in game. It worked perfectly. Capped my frames too.

This game is confusing.


Like I expalined before, as long as the frame rate is capped lower than the refresh rate, it won't increase loading times.
---
i5 2500k | Asus P8P67 M Pro | 4GB G.Skill | EVGA GTX 560 | 700W silent pro | CM Elite 340
#29lostlibrarianPosted 7/21/2012 5:51:12 AM
I assume you tried putting it on a solid state drive?
#30romsnbombsPosted 7/21/2012 6:27:02 AM
lostlibrarian posted...
I assume you tried putting it on a solid state drive?


That doesn't make any difference, because the load time is synced to the frame rate.
---
i5 2500k | Asus P8P67 M Pro | 4GB G.Skill | EVGA GTX 560 | 700W silent pro | CM Elite 340