This is a split board - You can return to the Split List for other boards.

What can improve texture loading speed for Sims 3 and CIv V?

#1fakewarsPosted 8/1/2013 2:39:41 PM
Better graphic card, faster HDD, or RAM?
---
"The heads of peasants are much better as footballs."
~Ningishzida
#2AnatomyHorrorPosted 8/1/2013 2:56:48 PM
I have Civ V on an ssd. Never noticed any textures missing/loading.
#3GoIrish80Posted 8/1/2013 2:57:37 PM
State your specs and what settings you're trying to run the games at.
---
i5-3570k @ 4.2ghz | 16GB DDR3 | Nvidia 670 2GB SLI | 1TB HD x2
#4ShebeskiiPosted 8/1/2013 4:27:19 PM
If you have enough RAM, SSD.

Civ 5 needs recent drivers. If you're using disk drivers for you GPU (as opposed to recent online ones), you may get the black texture glitch.
---
That which can be asserted without evidence, can be dismissed without evidence. - Christopher Hitchens
#5Snuckie7Posted 8/1/2013 4:30:14 PM
Nobody else gets a bunch of empty gray textures when loading up a game of Civ V for the first time?
---
Intel Core i7 3820 | EVGA X79 SLI K2 | MSI 7950 Twin Frozr III | Samsung / 840 120GB / 8GB RAM | 1TB WD Caviar Blue | Corsair / 550D / H70 | Silencer MKIII 600W
#6Bikes-Posted 8/1/2013 4:41:05 PM
Snuckie7 posted...
Nobody else gets a bunch of empty gray textures when loading up a game of Civ V for the first time?


I only find it to be a problem if you load in a game where you've already cleared out a good chunk of the fog of war.
---
FC: 2921-9087-2265
#7PhilOnDezPosted 8/1/2013 4:57:04 PM
I haven't played it much but I've never had any texture problems, whether new game or loading up a fully explored map. I've got Civ V Gold, 3570k (stock clocks), 8 gigs of ram, a 670, and it's installed to my 7200 rpm Barracuda. I assume it patched automatically to the latest version and I haven't modded it.
---
Every time I try to go where I really wanna be it's already where I am, 'cuz I'm already there
XBL, PSN, Steam, Origin, BSN, GFAQs, MC: PhilOnDez
#8Snuckie7Posted 8/1/2013 4:58:40 PM
Hmm that's odd. I usually play with a huge map size, so the gray textures/loading are always a problem for me.

I have 3GB of VRAM and Civ V is installed to my SSD too.
---
Intel Core i7 3820 | EVGA X79 SLI K2 | MSI 7950 Twin Frozr III | Samsung / 840 120GB / 8GB RAM | 1TB WD Caviar Blue | Corsair / 550D / H70 | Silencer MKIII 600W
#9PhilOnDezPosted 8/1/2013 5:01:36 PM
I have everything maxed aside from that one setting that lets you zoom in further, do you have that enabled? I can turn it on and see what it does
---
Every time I try to go where I really wanna be it's already where I am, 'cuz I'm already there
XBL, PSN, Steam, Origin, BSN, GFAQs, MC: PhilOnDez
#10ShebeskiiPosted 8/1/2013 5:02:23 PM
Snuckie7 posted...
Hmm that's odd. I usually play with a huge map size, so the gray textures/loading are always a problem for me.

I have 3GB of VRAM and Civ V is installed to my SSD too.


Has AMD ever included multithreaded rendering support for the game?
---
That which can be asserted without evidence, can be dismissed without evidence. - Christopher Hitchens