This is a split board - You can return to the Split List for other boards.

Anybody get Dead Space to work? Frame rate issues affecting controls etc

#21mjc0961Posted 8/16/2013 5:47:46 PM
coolpal23 posted...
So what would be the best solution?


Playing Dead Space on 360 or PS3 instead.

Terrible port is terrible, not much else can be said if forcing v-sync in your graphic card settings failed.
---
sirtonne posted...
This topic is so stupid I had to slap my wife.
#22JKatarnPosted 8/16/2013 6:12:02 PM
PhilOnDez posted...
JKatarn posted...
I would suggest leaving the in-game vsync setting off and forcing vsync in your control panel - this fixed the doorway issue for me and the game seems locked at 60fps with just a bit of control lag (note that I'm using the Steam version, not sure if the Origin copy is different).


Did you enable NCP vsync for the individual game or for your system as a whole? I already had it enabled for my system and I was still running the game at 250-500 FPS depending on what was going on, and even then I still couldn't turn at all while I was moving. I did finally get it running at 60 fps with PrecisionX but that wasn't via vsync which from what I've gathered here is what's causing my problem after the elevator room, and I still couldn't turn without stopping and just rotating the camera, even on min/max mouse sensitivity.

Doesn't seem like there would be different versions but I could be wrong. I'll see if maybe I'm missing a patch or something but I don't think there was ever a patch released for the pc version.


I enabled vsync for deadspace specifically in the control panel while leaving the in-game vsync option off (as it destroyed my performance for some reason to the tune of 10 or so FPS) - and I have been playing the game just fine since. I am using the Steam version of the game with GeForce driver 314.22
---
Asus P8Z68-V LE | Core i7 2600K | 8GB G.Skill Ripjaws DDR3 | Gigabyte GeForce GTX 660 Windforce OC
PS3 | PS2 | PSP| Wii | 3DS | DS | X-Box 360 | X-Box | NES
#23ShebeskiiPosted 8/16/2013 6:40:21 PM
JKatarn posted...
If you're referring to the in-game vsync, I had the same problem - enabling it turned the game into a "Quake on a 486" caliber slideshow for some reason, even though with the setting off the game runs silky smooth at max settings for me. You do need vsync enabled though or a bug in the physics engine means that the Necromorph that is supposed to come out of the door in that room never spawns, and you therefore cannot kill it which then makes that doorway passable. I forced vsync on in the Nvidia control panel and it solved that issue, though it did introduce a bit of control lag - enabling triple buffering mediated it to a degree (I'm playing the game with a PS1 controller and xbox360ce).


Forcing Triple buffering INCREASES input lag.

Only do it if you can't maintain 60FPS minimum.
---
That which can be asserted without evidence, can be dismissed without evidence. - Christopher Hitchens
#24JKatarnPosted 8/16/2013 6:54:03 PM
Shebeskii posted...
JKatarn posted...
If you're referring to the in-game vsync, I had the same problem - enabling it turned the game into a "Quake on a 486" caliber slideshow for some reason, even though with the setting off the game runs silky smooth at max settings for me. You do need vsync enabled though or a bug in the physics engine means that the Necromorph that is supposed to come out of the door in that room never spawns, and you therefore cannot kill it which then makes that doorway passable. I forced vsync on in the Nvidia control panel and it solved that issue, though it did introduce a bit of control lag - enabling triple buffering mediated it to a degree (I'm playing the game with a PS1 controller and xbox360ce).


Forcing Triple buffering INCREASES input lag.

Only do it if you can't maintain 60FPS minimum.


Ah, I think I was mixing it up with something else in my mind somehow. Still, it didn't perceptibly increase input lag for me personally, though I definitely have no problem maintaining 60fps minimum with this game so I suppose I should disable it. Thanks for the tip.
---
Asus P8Z68-V LE | Core i7 2600K | 8GB G.Skill Ripjaws DDR3 | Gigabyte GeForce GTX 660 Windforce OC
PS3 | PS2 | PSP| Wii | 3DS | DS | X-Box 360 | X-Box | NES
#25PhilOnDez(Topic Creator)Posted 8/16/2013 8:02:43 PM
Just got home. I set vsync specifically for the game and its working now. It still feels weird, I guess that's the negative mouse acceleration someone mentioned earlier, but it's definitely playable. Now to see if I can get past that door that was giving me trouble.
---
Every time I try to go where I really wanna be it's already where I am, 'cuz I'm already there
XBL, PSN, Steam, Origin, BSN, GFAQs, MC: PhilOnDez
#26Ch3wyPosted 8/16/2013 8:42:19 PM(edited)
Use a gamepad, it's what the game was made for. Mouse controls are absolutely terrible even with vsync on and all that jazz.

Fortunately that first door is the only well known high framerate related game breaking bug. I ran into it three or so times before I was able to get past it(Virtu MVP was keeping my framerate high), almost put me off the game completely. Right before the first save point so you have to watch a bunch of unskippable stuff before you can try again, extremely annoying.

Also if you still fail to get past it(vsync should do the trick), here's a save file I made of the first save point which is like right after it: http://www.mediafire.com/?8l549ineovx158l

---
Every time you point out that something is an opinion Jesus shoots a kitten in the face.
#27PhilOnDez(Topic Creator)Posted 8/16/2013 8:37:40 PM
Yeah, the unskippable cut scenes are the worst. They're the reason I almost gave up on hardcore mode on DS2, having to sit through that 7 minute thing every time I died. Another thing I noticed was Kendra's hair goes absolutely insane when your at 500 FPS, every time she moves her head it goes flipping around lol. It looked a lot more normal at 60.

Now I'm having a new problem unfortunately, I can aim and turn alright but the game is stuttering horribly. You'd think if I can run it at 3-500 FPS it could manage to stay at a steady 60 but it's just ridiculous how botched a port this game is.
---
Every time I try to go where I really wanna be it's already where I am, 'cuz I'm already there
XBL, PSN, Steam, Origin, BSN, GFAQs, MC: PhilOnDez
#28coolpal23Posted 8/16/2013 8:37:52 PM
Well i have vsync on..and It's stuck on 30 fps.
Urgh, I'm not used to playing on sub 60 fps settings.

IS there an option in CCC which will automatically vsync it to 60 fps?
---
|Asus Z77|Two 1Gb 7850 HIS XFire| 1866 8Gb G.skill| i5 3570K 3.4Ghz
Steam: Lyokofanatic[G77F] "Fact and fiction, where do you draw the line?"
#29DragnfyrPosted 8/16/2013 10:53:19 PM(edited)
I just started playing Dead Space 3 today and I turned Vsync off because I didn't think I would need it on my laptop playing at 1080p and because the Dead Space games have always had problems with vsync. However, it looks like this wasn't a very good port and Vsync is needed for smooth performance. With Vsync off I get 35-40 FPS but with many large spikes in frametime (7ms-100+ms) which caused a lot of microstuttering. I turned on Vsync and and I get a solid 30FPS with a flat 33ms frametime. Aiming feels the same as it before but the whole game is buttery smooth now. I know in Dead Space 1 it was better to leave Vsync off in-game but when you get to Dead Space 3 just leave it on and avoid wasting your time trying to figure out why the game is stuttering.
---
MacBook Pro with Retina Display | 15.4" 2880x1800 | Core i7-3615QM @ 2.3GHz | 8GB DDR3 1600MHz | GT 650M 1GB GDDR5 | 256GB SSD | OSX 10.8.4 | Windows 8 Pro
#30Mr_BankercatPosted 8/17/2013 2:12:13 AM
Tag