This is a split board - You can return to the Split List for other boards.

How to change refresh rate

#1XxTwisted26xXPosted 8/21/2013 9:40:43 AM
Okay last PC question I promise :). I thought my monitor was changing brightness automatically, and Ive been trying to figure out the past few days why it is when power saving modes are off.

Then I read about refresh rates and those at lower your displays refresh rate can cause flickering of lights, which sounds like what's happening on my monitor.

Monitor: Samsung T240HD @75Hz (states so in CCC) with HDMI cable
GPU: SAPPHIRE 100351SR Radeon HD 7970

When i go into advanced display options and go to refresh rate, it says my refresh rate is at 60 and it has no other options to change. It says online that anything less than 75 will cause flicker. And yes I updated to newest GPU driver.
---
Steam: xxtwisted26xx
"When you play the games of thrones, you win or you die. Theres no middle ground" - Cersei Lannister to Eddard Stark
#2fataliPosted 8/21/2013 10:03:44 AM(edited)
Says in the manual of your monitor the max resolution is 1920 x 1080p at 60 Hz.

It would probably only accept 75Hz with a lower resolution, the input signal processor just doesn't have the speed to process the amount of data to reach 75Hz at the max resolution.

The flickering you read about, would be a very fast flashing, that moves on waves across the screen, not just a change of brightness.

---
Mystery is the source of all true science.
#3XxTwisted26xX(Topic Creator)Posted 8/21/2013 10:14:19 AM
Ah so it is auto changing brightness then. Gah, if its not one thing with this PC its another >_<. Thank you for your response!
---
Steam: xxtwisted26xx
"When you play the games of thrones, you win or you die. Theres no middle ground" - Cersei Lannister to Eddard Stark
#4fataliPosted 8/21/2013 2:59:09 PM
Reading further on the manual, seems your monitor has some energy saving features, where it dimms the light of the LCD panel, you can turn that off in the monitor menu.
---
Mystery is the source of all true science.
#5XxTwisted26xX(Topic Creator)Posted 8/21/2013 3:01:45 PM
fatali posted...
Reading further on the manual, seems your monitor has some energy saving features, where it dimms the light of the LCD panel, you can turn that off in the monitor menu.


Yeh I think something is wrong with the monitor. I have Energy Saving mode turned off but it still auto dims. Also, every now and then the screen will turn black for half a second. Maybe once an hour. Its not that bothersome, but its noticed by how many times its happened lol.

And for the screen size, in the monitor settings only Wide and 4:3 are choosable.

16:9, Zoom 1 and 2, Wide Fit, and Just Scan are blacked out. Is that normal?
---
Steam: xxtwisted26xx
"When you play the games of thrones, you win or you die. Theres no middle ground" - Cersei Lannister to Eddard Stark
#6XxTwisted26xX(Topic Creator)Posted 8/21/2013 3:56:36 PM
Okay, so when I change the screen resolution to anything below 1980x1200 it lets me choose all screen options like just scan. But above that theyre all blacked out :/
---
Steam: xxtwisted26xx
"When you play the games of thrones, you win or you die. Theres no middle ground" - Cersei Lannister to Eddard Stark
#7XxTwisted26xX(Topic Creator)Posted 8/21/2013 3:59:49 PM
Im wondering if I needed to calibrate the monitor as well? I just plugged it in and started using it.

For the auto changing brightness, people said it might be MagicBright doing it, but there's no option for it in my menu settings.
---
Steam: xxtwisted26xx
"When you play the games of thrones, you win or you die. Theres no middle ground" - Cersei Lannister to Eddard Stark