This is a split board - You can return to the Split List for other boards.

So.. Im trying to get Battlefield 3 to work.

#1rwfan2cPosted 8/21/2013 7:01:59 PM
I Bought it cause it was on sale Even though my Laptop is pretty crappy, I Have not run into a game that i could not play. Even on Lowest Settings The Witcher 2 ran at like 40-55 FPS.

I figured worse case Scenario The game would be really laggy and i would just have to wait till November when i finish building My New Desktop (Well Mostly by friend will finish building it, I will provide the parts.. lol)

So I get it installed and much to my surprise the game doesn't start... it goes to the battlelog and as far as i can tell there is no way to just launch the game to the Main menu.... Ummm.. Okay...

So I try to join a game. Wait 2 minutes, Game Never opens up and i get a crash Notice. Try again, same thing happens. Try launching campaign, This time the screen goes black as if it were going to actually open the game annnnd Crash Notice.

So i download this Program to change the Settings of B3 without having the game open. Put everything on Minimum settings. Same result.

Restart My Computer. Same result.

Go to Checkreq and this is what they said.


"Problems may occur

Performance level of video card may cause, that normal fluidity of playing can be achieved only on the lowest (perchance medium) game's parameters. It should also be sure to install the latest version of the graphics driver. If you can not start the game, and this result points to something else, for integrated video card, it needs to increase the size of the buffered memory (in the BIOS)."

Now as someone who knows very little about PC's i have no clue what that means. I am Pretty sure, however, that i have an Integrated Video Card.

Is there anything i can do? Or am i just boned till i get my Desktop built?
---
Currently Playing: Guild Wars 2, Bastion, Tera, Far Cry 3
"Demon's Run, When a Good Man Goes to War."
#2bikeblasterPosted 8/21/2013 7:02:42 PM
drivers
---
2500k @4.2 GHz | Z68X-UD3P | Hyper 212+ | 8GB Corsair Vengeance | GTX 670 | Samsung Spinpoint 1 TB+WD 320 | Win 7 64-bit | Corsair 750HX| CM 690 II Adv
#3rwfan2c(Topic Creator)Posted 8/21/2013 7:03:23 PM
bikeblaster posted...
drivers


You Saying to Update them?
---
Currently Playing: Guild Wars 2, Bastion, Tera, Far Cry 3
"Demon's Run, When a Good Man Goes to War."
#4DerPancakePosted 8/21/2013 7:04:32 PM(edited)
Whats your CPU?

I had that problem when using a Dual Core CPU.
---
i7-4770k | EVGA GeForce GTX770 2GB | Asus Sabertooth Z87 | Corsair Vengeance 8GB RAM
Samsung 840 120GB SSD | CM Storm Enforcer | Corsair TX 750 Watt
#5rwfan2c(Topic Creator)Posted 8/21/2013 7:06:40 PM
Yea Mines a dual Core. Prob Nothing too good. Heres what Checkreq says it is.

Intel(R) Core(TM) i5-2450M CPU @ 2.50GHz
---
Currently Playing: Guild Wars 2, Bastion, Tera, Far Cry 3
"Demon's Run, When a Good Man Goes to War."
#6LordSeiferPosted 8/21/2013 7:12:58 PM
rwfan2c posted...
i have an Integrated Video Card.

---
^ this
#7Greendragon854Posted 8/21/2013 7:16:40 PM
It's a long shot, but when the game first launched I had the same kind of problem. Turns out it was a problem with my phillips amBX drivers. Someone on gamefaqs asked if I had it by chance (no idea why they would have suggested that since amBX is something like...no one has) but I disabled it and it ran perfectly (aside from the occasional punkbuster crashes I've had.)
---
"Are you going to buy this time? Or are you still just curious?"
"Well, I supposed you could say I'm Buy-Curious" ~PSN - greeniebeanie
#8rwfan2c(Topic Creator)Posted 8/21/2013 7:30:05 PM
bikeblaster posted...
drivers


Thanks dude. Aparently My Drivers were insanely out of date... Updated them and it works fine now. ^^
---
Currently Playing: Guild Wars 2, Bastion, Tera, Far Cry 3
"Demon's Run, When a Good Man Goes to War."
#9spud_almightyPosted 8/22/2013 6:05:45 AM
rwfan2c posted...
bikeblaster posted...
drivers


Thanks dude. Aparently My Drivers were insanely out of date... Updated them and it works fine now. ^^


Apparently? Do you not check them?
#10PhilOnDezPosted 8/22/2013 6:10:17 AM
I've updated IGP drivers maybe once in my life. I say maybe because I'm not even sure if I actually got them, I just hit the "Scan for new drivers" button and it may or may not have found anything.
---
Every time I try to go where I really wanna be it's already where I am, 'cuz I'm already there
XBL, PSN, Steam, Origin, BSN, GFAQs, MC: PhilOnDez