This is a split board - You can return to the Split List for other boards.

Need some help running Battlefield 1942

#1JimmyGibbsJRPosted 8/26/2013 4:13:55 PM
I recently installed origin (which isn't actually that bad) to play some bf1942. I downloaded the game, and went to launch it. What happened was instead of launching the game, nothing happens. Its pretty much like I never clicked launch. I'm running windows 7 with these specs: 3.6 GHz athlon 640, 7790, 8 gigs ram.
#2Kingmichael1337Posted 8/26/2013 4:18:41 PM
that happened to me when i tried to play mass effect on steam. i had to fix it by running steam as administrator, so maybe you could try that with origin.

it also happened to me with deus ex: human revolution, but in that case, i had to fix it by going to device manager and disabling my integrated graphics that i wasn't even using anyway. not sure why i had to do that, but it worked after.
---
I'M GAY.
#3JimmyGibbsJR(Topic Creator)Posted 8/26/2013 4:51:59 PM
Tried that, didnt work. Thanks anyways.