This is a split board - You can return to the Split List for other boards.

Bioshock 1 unplayable (sound issue) / Would sound card fix this issue?

#1dlfPosted 8/30/2013 5:08:16 PM
- What is the problem? - Steam copy (and my only PC copy) will not boot if I don't have a '-nosound' command in the launch options of my steam copy. Will run if I input said '-nosound' command in launch options
- Where is the problem happening? Game Start up
- What version of the game do you have (Steam / Retail ) - Steam
- What platform (PC / Xbox360) - PC
- Are other people having this problem? - I'm sure other people have had this issue.

Specs:

- CPU: Intel Core i7-3770K 3.5GHz Quad-Core Processor ($314.99 @ Newegg)
- Motherboard: Gigabyte GA-Z77X-UD5H-WB ATX LGA1155 Motherboard
- Memory: G.Skill Ripjaws Series 8GB (2 x 4GB) DDR3-1600 Memory ($66.99 @ Newegg)
- Video Card: PowerColor Radeon HD 7970 3GB Video Card ($279.99 @ Newegg)
- Optical Drive: Asus DRW-24B1ST/BLK/B/AS DVD/CD Writer ($24.98 @ Newegg) [x2]
- Operating System: Microsoft Windows 7 Ultimate Full (32/64-bit) ($319.99 @ Newegg)

- DirectX Version: DirectX 11
- Graphics Card Name: PowerColor Radeon HD 7970 3GB Video Card
- Graphics Card Memory: 3 GB
- Graphics Card Driver Date & Version: 13.2(What ever drivers AMD released on the 1st of this month). 7/23/2013 (is what Dxdiag says)
- Sound Card Name: Audio device: Speakers (Realtek High Definition)
- Sound Card Driver Date & Version: 3/29/2013 & 6.00.0001.6873)

Link to my dxdiag - http://www.mediafire.com/?ifbl4n4xfeakcoc

What I've tried to do to resolve this:

- Put '-nosound' in the launch options of the game (it will boot, but I want sound
- Compatibility (trying to run the exe with Vista/XP compatibility set, not the actual OS)
- What the 'START HERE > BioShock 1 - How to fix: Sound + Start-up Bugs! [2/2/10]" thread @ the bioshock forums on steam have suggested.

- Could I have not connected something to the motherboard like F_Audio or HD_Audio? - Stupid question but I can see where they connect to the motherboard, but what of the other end?
- Could a sound card (http://pcpartpicker.com/parts/sound-card/) help - or would it be a waste of money?
---
I have built http://pcpartpicker.com/p/P5kr - Minus a few parts.
#2steveboblarryPosted 8/30/2013 5:09:16 PM
I think you have to plug in a mic or something, been a while since I played it can't remember what I did to fix it.
---
Chief Keef makes music for people who spin around in circles to get dizzy
#3dlf(Topic Creator)Posted 8/30/2013 5:11:25 PM
Stand alone mic or could a head set be tried? I doubt we have a stand alone mic, or a head set that's not bluetooth.
---
I have built http://pcpartpicker.com/p/P5kr - Minus a few parts.
#4ajko000Posted 8/30/2013 5:12:17 PM
You have to enable Stereo Mix under the Recording Devices tab.
#5dlf(Topic Creator)Posted 8/30/2013 5:13:51 PM
One of the first things I did after installing the game and seeing it wouldn't boot and reading suggestions online. Hasn't done a thing for me.
---
I have built http://pcpartpicker.com/p/P5kr - Minus a few parts.
#6spendog8Posted 8/30/2013 5:18:15 PM
I had a sound issue with bioshock 1, i just took off steam overlay and it started working. dunno if its the same issue as yours though.
---
Brothers everywhere raise your hands into the air we're warriors, warriors of the World.
XFX 7970 DD CF, 1100T @ 4.0GHz
#7GreenMage7Posted 8/30/2013 5:21:24 PM
Well after a couple of similar threads were solved in this fashion I am just going to recommend it be tried for every problem.

Did you try running Steam itself as an administrator? Worth a shot.
#8dlf(Topic Creator)Posted 8/30/2013 5:37:02 PM
I have now and that didn't do a thing, nor changing the language to French. I guess I could try a mic, again a stand alone mic or headset (bluetooth?) also headphone or mic port? I'd presume mic.
---
I have built http://pcpartpicker.com/p/P5kr - Minus a few parts.
#9poidapoidaPosted 8/30/2013 8:25:29 PM
That's strange, the game would still run for me it just didn't have any sound. I plugged in my headset and it worked perfectly.
#10iXCeeDPosted 8/30/2013 8:27:45 PM
well try VAC worked for me if you cant find the stereo mix. just type vac on google