This is a split board - You can return to the Split List for other boards.

Rome total war 2's optimization, holy crap.

#41JKatarnPosted 9/6/2013 4:35:52 PM
rkpeagle posted...
Nicodimus posted...
PSP_H0mebrew posted...
Just an Update:

People found the graphics/performance problem.

The game does not auto detected and run using your GPU/Video Card. It uses your Integrated GPU. To fix this go to the Nvidia control panel, or whichever software your GPU uses, and force it to use your card.

Thats pretty damn bad for a game released in this day and age but ok, glad to have that problem fixed.

Wow...pathetic quality control. Nobody noticed this?

This is like common sense, even Shogun 2 did the same.

Um no, that's not really common sense, as long as your BIOS is set to use/prioritize your PCI-E card(s), you shouldn't have to set a control panel setting, and I never had to do that for Shogun 2 and I'm using a Sandy Bridge with integrated graphics.
Asus P8Z68-V LE | Core i7 2600K | 8GB G.Skill Ripjaws DDR3 | Gigabyte GeForce GTX 660 Windforce OC
PS3 | PS2 | PSP| Wii | 3DS | DS | X-Box 360 | X-Box | NES
#42NingishzidaPosted 9/6/2013 6:03:08 PM
PSP_H0mebrew topic